Not allowed to use Amplify Video

restapi
video-app-download
media-upload
promoted-tweets

#1

Hi, I am trying to upload a promoted video by following the process here: https://dev.twitter.com/ads/creative/promoted-video-overview

But I am keep on getting the following error, and it appears to be some permissions issue. How can I grant myself the ability to use AmplifyVideo?

{'request': '/1.1/media/upload.json', 'error': 'User XXXX is not allowed to use Some(AmplifyVideo) media category.'}

My python code is below, any help is appreciated. Note that using “tweet_video” works, but those videos can’t be used in ads.

request_data = {
    'command': 'INIT',
    'media_type': 'video/mp4',
    'total_bytes': total_bytes,
    'media_category': 'amplify_video',
    #'media_category': 'tweet_video',
    'additional_owners': xxxxx
}

req = requests.post(url='https://upload.twitter.com/1.1/media/upload.json', data=request_data, auth=oauth)
print(req.json())

Updated 2017-04-24:
I just tried running my code again today and it worked. I didn’t make any code changes so I am not sure what the problem was. Was there some problem with this endpoint on Friday and it got fixed today?


#3

@kent_mz1: Thanks for the question and apologies for the delay. Please see this post for additional information on uploading videos.