Not allowed to create app despite having mobile phone linked


#1

So I am trying to create a twitter app on https://apps.twitter.com/app/new and my twitter profile does have a mobile phone linked to it. Even verified it, too!

However, when I press Create your Twitter application… I get

Error
You must add your mobile phone to your Twitter profile before creating an application. Please read https://support.twitter.com/articles/110250-adding-your-mobile-number-to-your-account-via-web for more information.

So… I don’t know.


#2

Same deal here. Super frustrating.


#3

I’ve been experiencing the same problem. Glad it’s not just me, but where’s the fix?


#4

I thought maybe was a cache issue but tried another browser as well and no dice.


#5

We’re looking into this - ticket internally is PREL-14541


#6

Frustrating. Now have 5 different suppliers sim cards surrounding me & the issue is something with twitter. AH well, suppose 4 hours is not so bad to loose.


#7

Any update on this ticket number for us external people. PLEASE


#8

This issue is affecting a new account that I created yesterday and verified the phone for today (@3rdWaveYT), but I’ve also tried with my older account that had a phone verified with it about a year ago and it worked fine (@yeddish).


#9

Affects older accounts which never had phones verified as well. Old accounts with API already on can even create more. If verify phone for first time, NO APP. Just get rid of mobile verification for API keys. It’s 2015.


#11

Same very frustrating thing.


#12

Just hit this issue too :frowning:


#14

Same issue . Any update :confused: ?


#15

I have found a solution.

Got to https://mobile.twitter.com/settings and click on mobile notifications. Yours should be in the ‘off’ position. Turn it on and you should be good to go!


#16

No, you have not found a solution, because that is false.

Within settings > notifications there are several options and no combination of them on or off will allow you to create an app.


#17

Hi everyone - apologies for this issue - I’ve just posted an update on the Announcements forum.


#18

same problem here :frowning:


#19