Nondeterminstic behavior for lists/members/create_all

rate-limits
rest

#1

lists/members/create_all does not always add the user ids specified in the request.

Sometimes 100% of the users passed to the request are added to the list, sometimes only a couple of users are added, sometime no users at all are added.

I am limiting the number of user ids in a single request under 100 as specified in the docs, and am not trying to add more than 1000 users to the list in total, so this behavior is surprising.

The doc states:

Please note that there can be issues with lists that rapidly remove and add memberships. Take care when using these methods such that you are not too rapidly switching between removals and adds on the same list.

But there is no detail on how often lists can updated, or what specifically causes a list to enter the state where the behavior of the API call becomes nondeterministic.

Any help would be appreciated.


#2

Are you saying that the same call can behave differently with an identical set of user IDs on each call?

Just wondering, but are any of the accounts in the list of users you’re trying to add to the list protected?


#3

Are you saying that the same call can behave differently with an identical set of user IDs on each call?

Yes. I perform the same lists/members/create_all call again and again with the same list of ids and the resulting member_count is unpredictable - sometimes no users is added, sometimes 2 are added, etc.

Just wondering, but are any of the accounts in the list of users you’re trying to add to the list protected?

Possibly a very small percentage of them are protected (<10%). Would that cause the entire call to fail or misbehave?

To give more information, the experiment I’m running involves grabbing the ids that some Twitter user follows using friends/ids/ and then adding them to my own private list with lists/members/create_all (50 ids at a time, with timeouts in-between).

The usecase I’m interested in is being able to remove all the users in a list and replace them with 1000 new users once a day. Would that be within rate limits?

(Right now it’s hard to test anything because it seems that I am blocked from the entire lists API - I even get “Not Allowed” errors when I try to add a user to a list from the normal Twitter website.)


#4

This is precisely why I asked the question about the similarity of calls. If you can provide us (privately of course) with a list of IDs that demonstrate this unexpected behaviour, I get it. If some of the users are protected etc I can imagine that there’s a chance that subsequent user IDs might cause the whole post to fail (I’m not saying this is a good thing - I’m just exploring the situation).


#5

I’m experiencing the same issue, and I filtered out the protected profiles before.

Adding members to lists via API is simply unreliable. I can provide user IDs and anything else is required to solve the issue. Can anybody please help? Thanks!


#6

Hey did it recover for you? I got stuck as well can’t even add to lists manually…


#7

Hey there guys, I’m getting pretty much the same thing. Yet majority of the time I get 0 members being added, even though the call is the same, and my screen_names are not protected.

In my first attempt , I got 497 people added, out of 499. Then I tried a larger list which only got 147 out of 1000. Following this I got an error back of “Over Capacity”. Subsequent calls I’m lucky to get 1 name added to my lists.

@andypiper any further ideas yet?


#8

At this point I’m just creating a new list at most once a day. It’s not ideal at all, but sufficient for my project.


#9

Unfortunately I’ve been deep in prep for @Flight so haven’t had a chance to dig deeper. Bear with me.


#10

Appreciate the effort Andy!


#11

They say you have to add 100 at a time
https://dev.twitter.com/rest/reference/post/lists/members/create_all

I’m doing that and sleeping 100 seconds between subsequent calls but it still gets stuck after few times. Hoping @andypiper gets back to us, cheers.


#12

I first noticed this behavior around the beginning of July along with others that work with lists extensively. At the time, I assumed it to be a new, secret rate-limit (or at least was not updated in the docs, I know docs can trail behind). But, glad to see this thread since it is still happening and the docs have not been updated, if indeed it is a rate limit of sorts.

I can confirm that the call behaves differently with a identical set of user IDs, which was why I assumed it was some type of limiting.

I can also confirm that once it starts happening (not all users added in the create_all) then attempts in the native Twitter Apps/site to add a member to a list also fail, again pointing to some limit on the user in the number of memberships that can be created in a given period. The error message in the Twitter web site is “Your account may not be allowed to perform this action. Please refresh the page and try again.”


Lists/members/create_all not adding people to a list
#13

I’ve ran in the exact same problem.

Can’t figure the origin: not related to ids, number of calls, existing list or not, and no error code.
It just worked fine 2 months ago (well, not after creating several listsx). Now, it just add very few people (sometimes 0, sometimes ~ 20). So I need to to make the call dozen of times to add up to 3k members.

Other issues related:



#14

@andypiper Have you had a chance to dig into this? Let me know if you need more sample requests/description.


#15

Has anyone found a fix for this or a workaround? I’m unable to use create_all to add accounts. As others have said, there appears to be some type of limiting on Twitter’s end or just an outright bug. Sometimes 1 account out of my list will get added, sometimes 0, etc. It is very erratic.

I may just use the create endpoint to see if that works better, but adding the 1,000 max for a list would be a lot of unnecessary API calls.

Also, I’m getting a 200 response back from the API even though none of the ids in my list are ever added. It’s very strange.


#16

I’m getting this same behavior using the REST API. In addition, attempts to add any users to a list on the account I use for testing also result in the “your account may not be allowed to do this” error mentioned above.

Please? Is there a rate limit or limitation to be aware of so that we’re not triggering this result?

We’re limiting our calls to this API to once each 10 minutes, and a max of 100 users added to the list each time. Should be well below the API limits as published.


#17

I’m experiencing the same behavior here:

  • 200 ‘OK’ response from the API but members frequently not added
  • No rates limit appear to change after I call the create_all endpoint
  • As soon as I notice an issue, any attempt to add a user to a list through the twitter website result in the “your account may not be allowed to do this” message to pop

Am I missing something about this particular endpoint ? is there a limit on the number of users one can add to lists for a given amount of time ?


#18

We’re experiencing the exact same thing, for what it’s worth


#19

Can someone from Twitter put the time to at least confirm the existence of this bug? It’s been almost half a year and a lot of people are reproducing this issue.


#20

6 months later, same problem.

@andypiper please deliver us from this hell.