No stats for video adsS Twitter campaign


#1

I have campaign as per below

[
{
“DailyBudgetAmountLocalMicro”: 3350000,
“TotalBudgetAmountLocalMicro”: 16750000,
“AccountId”: “18ce54gmv3v”,
“Currency”: “USD”,
“FundingInstrumentId”: “q1v61”,
“ReasonsNotServable”: [],
“created_at”: “2018-01-25T21:40:13Z”,
“start_time”: “2018-01-25T21:40:03Z”,
“end_time”: “2018-02-24T21:01:53Z”,
“deleted”: false,
“entity_status”: “ACTIVE”,
“servable”: true,
“standard_delivery”: false,
“Id”: “a9lpa”,
“Name”: “192739273-02”,
“updated_at”: “2018-02-22T10:05:52Z”
}
]

I have line item attached to the campaign as per below

[
{
“BidAmountLocalMicro”: 670000,
“BidUnit”: “LINK_CLICK”,
“ChargeBy”: “LINK_CLICK”,
“TotalBudgetAmountLocalMicro”: null,
“AccountId”: “18ce54gmv3v”,
“PrimaryWebEventTag”: null,
“Name”: “Untitled”,
“CampaignId”: “a9lpa”,
“Currency”: “USD”,
“IncludeSentiment”: “POSITIVE_ONLY”,
“bid_type”: “MAX”,
“ProductType”: “PROMOTED_TWEETS”,
“Placements”: [
“PUBLISHER_NETWORK”
],
“Objective”: “WEBSITE_CLICKS”,
“Optimization”: “DEFAULT”,
“created_at”: “2018-02-22T22:41:35Z”,
“deleted”: false,
“entity_status”: “ACTIVE”,
“Id”: “b47bx”,
“updated_at”: “2018-02-22T22:41:37Z”
},

I tried to get the stats as per below

{
“data_type”: “stats”,
“time_series_length”: 1,
“data”: [{
“id”: “a9lpa”,
“id_data”: [{
“segment”: null,
“metrics”: {
“impressions”: null,
“tweets_send”: null,
“billed_charge_local_micro”: null,
“qualified_impressions”: null,
“follows”: null,
“app_clicks”: null,
“retweets”: null,
“likes”: null,
“engagements”: null,
“clicks”: null,
“card_engagements”: null,
“poll_card_vote”: null,
“replies”: null,
“url_clicks”: null,
“billed_engagements”: null,
“carousel_swipes”: null
}
}]
}],
“request”: {
“params”: {
“start_time”: “2017-12-01T04:00:00Z”,
“segmentation_type”: null,
“entity_ids”: [“a9lpa”],
“end_time”: “2018-02-23T11:00:00Z”,
“country”: null,
“placement”: “PUBLISHER_NETWORK”,
“granularity”: “TOTAL”,
“entity”: “CAMPAIGN”,
“platform”: null,
“metric_groups”: [“ENGAGEMENT”,
“BILLING”]
}
}
}

{
“data_type”: “stats”,
“time_series_length”: 1,
“data”: [{
“id”: “a9lpa”,
“id_data”: [{
“segment”: null,
“metrics”: {
“impressions”: null,
“tweets_send”: null,
“billed_charge_local_micro”: null,
“qualified_impressions”: null,
“follows”: null,
“app_clicks”: null,
“retweets”: null,
“likes”: null,
“engagements”: null,
“clicks”: null,
“card_engagements”: null,
“poll_card_vote”: null,
“replies”: null,
“url_clicks”: null,
“billed_engagements”: null,
“carousel_swipes”: null
}
}]
}],
“request”: {
“params”: {
“start_time”: “2017-12-01T04:00:00Z”,
“segmentation_type”: null,
“entity_ids”: [“a9lpa”],
“end_time”: “2018-02-23T11:00:00Z”,
“country”: null,
“placement”: “ALL_ON_TWITTER”,
“granularity”: “TOTAL”,
“entity”: “CAMPAIGN”,
“platform”: null,
“metric_groups”: [“ENGAGEMENT”,
“BILLING”]
}
}
}

All is in ACTIVE status, but still the stats is returning NULL for all parameter, both PUBLISHER_NETWORK and ALL_ON_TWITTER placement.

Can someone please help to clarify what is wrong with this campaign that it doesnt generate any impression and clicks?


#2

@fahad1k: null values indicate that there is no data—e.g., the ad did not serve—for that entity for the given time range. See this post.

Our team doesn’t provide guidance around campaign management. The advertiser’s account team, if they have one, would be the best source. Otherwise, you can try to reach out using the “Help?” link on the top right of the ads.twitter.com page.