No Metatags Found


#1

I am working on a site that will heavily rely on twitter cards. I’ve built my pages, and was going to test them out using the Twitter Card Validator.

Unfortunately, for some reason, the validator is saying that the page was fetched successfully and no metatags were found.

I did a manual cURL to make sure everything looked correct - the HTML is in this gist.

I even tried copy and pasting the sample code from the Summary with Large Image documentation. No luck, same thing

I’ve stripped out unnecessary HTML, moved the meta tags to the top… still nothing.

Any ideas of why the validator might not be finding my meta tags? There are a few other similar posts on these forums, but none of them have answers. What’s going on?


#2

We have the same issue at CorradoG60.com and all was well until maybe a few weeks ago. Out of interest, do you use CloudFlare or anything similar?


#3

I’m not using Cloudflare. I’ve tested both locally (using ngrok) and against the version I have running on Heroku.


#4

I am having the same issue. I use Yoast SEO plugin for Wordpress and the code looks exactly like the directions say it should look, but I still get the same error message, making it impossible for me to get my site validated. Does Twitter monitor this forum?


#5

Yes, we do - but many of us have been out on vacation, and we cannot always answer every individual question. We are really sorry that this is biting people at the moment, and will be looking into it.


#6

Thanks Andy. That was meant to be a question, not a complaint. This was my first post here and I wasn’t sure if anyone from Twitter participates. I’m happy to hear that you do! Thanks for looking into this issue.


#7

No problem - we (the @TwitterDev team) try to help where we can!


#8

Any word on this? I am still facing the issue. I cannot launch my website until I get twitter cards set up - please help!


#9

Do you have a link to the page you are trying to validate?


#10

Yeah, you can test at this link: http://www.getsocialcards.com/f19e


#11

Sorry to pester, but did you find any hints with that URL? Any ideas why I might not be able to validate my card?


#12

Popping in to comment that I’ve getting the same issues. I’ve got a PHP script that acts on my domain that helps add the metatags to a direct link to the image. i.e., http://chloelemaire.com/f/8.png actually calls http://chloelemaire.com/f/image.php?image=8

The resulting page has the following meta tags (and you can check this for yourselves):

<meta name="twitter:card" content="photo" />
<meta name-"twitter:site" content="@puddizzle" />
<meta name-"twitter:title" content="8.png" />
<meta name-"twitter:image" content="http://chloelemaire.com/b/8.png" />
<meta name="twitter:url" content="http://chloelemaire.com/f/8.png">

/b/8.png is where the actual image is held. The tags seem to be in order, but the validator says no metatags found. Any ideas?


#13

Hey - any update? I need to get this site launched, and can’t do anything until this is resolved.

Can I at least get word that someone is looking at this?


#14

According to the validator this site validates and your site is approved, so this should just work at this point. I see a summary card when I tweet the link.


#15

Try meta name= instead of meta name- (the broken syntax highlighting was what made me spot the issue here)