No metatags found, but I can see them


#7

I am having a similar issue with this URL. The CMS is Squarespace 7. I can see the meta tags.
http://www.robpratt.co/blog/2014/11/19/its-not-me-its-uber


#8

@andypiper @romainhuet – any additional suggestions? Or known issues with the Validator? Squarespace told me they tested the validator and it found my meta tags, so perhaps it’s intermittently functioning or not functioning as expected. I’d love to regain Twitter card support for my websites.

Thank you!


#9

So, any development? It’s been a while that this issue was posted and we still didn’t had a proper fix. The last post was 28 days ago, but there’s been no answer yet.


#10

Yes, a resolution would be great. The same thing is happening to a large, electronic site I manage that is depending on Twitter during CES.

Thanks!


#11

@yuliat79, what’s the url that’s causing problem for you?
@cfohlin,@pixelsebi your page is rendering fine in the validator for me, but it’s not whitelisted. Can you try again please? If it still doesn’t work, can you please give me the ip where you’re trying from? I can try to see if it’s geo/data center issue
@Rob_Pratt, your page is missing the twitter:card meta tag
@dana11235, I’m looking into why it’s not working for your site now.


#12

I had removed the code. It’s back, and the issue still remains.


#13

@yhenry My website still doesn’t work with the cards validator, I still get a Warn: No metatags found error. My website is http://lawgier.net and it’s running on Squarespace 7.
Thanks.


#14

I’m having a similar issues. My twitter cards were working in October but now when I try to validate them I get back “no metatags found”

I’m trying to validate http://www.wannawatch.it/


#15

BTW, I finally got it working after finding the answer here:

In short, I needed to set Content-Type to text/html. I guess that my server wasn’t setting it by default…


#16

I have the same issue. I have tried to validate this article http://www.burtonmail.co.uk/plans-56-homes-Etwall/story-29255076-detail/story.html but it says ‘no meta tags found’. I can clearly see the meta tags in source code. Later, I have tweeted the same article and card is not getting displayed ( see the img 1 ) and again i refreshed the page and tweeted it is getting displayed a card ( see the img 2 )



#17

Hi Twitter.

I’ve encountered the same problem with cards at https://thrivous.com

I’ve reviewed all the items mentioned in this thread, and none has solved the problem. Maybe it’s a whitelisting issue? Would you please advise? Thank you!


#18

When I fetch your site using curl -A Twitterbot (ie using the Twitter crawler’s user-agent instead of being a web browser) it returns a bunch of empty Twitter card tags, and a different result to if I fetch it with curl -A Safari, for instance.

There’s another thread here you should check - there is no need for whitelisting and this is a misleading error.


#19

Thanks, Andy, for pointing me in the right direction.


#20

Greetings, fixing header to content-type:text/html fixed the issue
you can check your headers with curl -I domain .com/post (together) or some website tools by google “check website header”


Channel closed
#21

I am getting this error for the first time on all the pages on my site starting this morning. I have checked all the suggested troubleshooting tips. The interesting thing is here is a cached version of a card for a page I have not modified:

http://www.tennisrecruiting.net/article.asp?id=2495

If I add an additional parameter to the querystring, I get the “No metatags found” error:

http://www.tennisrecruiting.net/article.asp?id=2495&v=2

This is just an issue with the Validator. The cards appear to display fine in the tweets. It’s always nice to check them before sending out, though.


#22

I’m also having the same issue, it says “WARN: No metatags found” on the card validator, though I can see metatags on my page. It started happening yesterday and isn’t working on any page new now.
Here’s the url: http://www.technobrunch.com/featured/tweets-thatll-make-you-question-life/


#23

We made some infrastructure changes on our side last week that caused a temporary glitch for some cards, and we apologise for the inconvenience. In most cases this should resolve when the URL can be recrawled after the caching period has expired in around 7 days. I’m looking into anything else that might be possible to help to resolve these issues if that’s not the case.


#24

@TennisRecNet @TechnoBrunch it looks like this could be working for your links now.


#25

Thanks, it’s working now :slight_smile:


#26