No Meta Tags on some posts while other ok?


Description of issue:
Ok, so I’ll give you a disclaimer that I have no clue what I am doing. I am currently running a RPG podcast from a Wordpress website. I am using the SEO Yoast software with all my posts to make them Twitter friendly. I am having mixed results with this. My most recent post will not fetch the meta tags.

Yet last month the following post worked just fine.

I have viewed the source (like that helps in my case), and nothing look extremely different from my untrained eye. I’ve also went through the troubleshooting guide to the best of my ability but was unable to turn up anything.

Can anyone give me a hand. I am almost to the point of signing up for SquareSpace and totally redoing everything.



Hi @RPExchange - thanks for writing in. Have you read the section on Wordpress plugins in our announcement here.

  • are you using a Wordpress (or other CMS/blogging platform) plugin? We provide our own official Wordpress plugin , but cannot easily provide support for those built by third parties . Check that the configuration includes all of the required tags. Avoid using multiple plugins at the same time, as tags will override one another.

This might be causing the issue.


I have went through the trouble shooting steps you suggested and everything appear to be alright.

I have disabled SEO Yoast and tried the official Twitter app. The results are the same.

Any suggestions? Any ideas why only certain posts go through?


hey there! As @Aurelia correctly mentioned, we can only support out own code (although we love that so many third parties build plugins to integrate with Twitter). I would speculate that your blog posts are not getting all the relevant tags inserted. Can you check that in your source code?


I am using the Twitter app right now.

Here is an excerpt of the post in question. This one does not work.

And this one does work. I can’t see any difference.

closed #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.