No data returned from Twitter public stream api


#1

Our public stream did not return any data since around 8:00 pm 01/13, pacific time. I wonder what was going on. thanks


#2

I just checked stream.twitter.com and the sample endpoint and I’m receiving data.

Is there a chance that there was an interruption to the network connection on your side?


#3

I have been facing the same issue on a VM hosted on Windows Azure. Two of my apps using streams have stopped receiving any data from the stream. The connection does not throw any error. Just that no content is returned from the public API even when content is matching the filters.


#4

Does this issue persist even if you restart the connection?


#5

Yes. Even after a restart the issue persists. Other APIs are working fine. The Stream API has been running well for more than 3 months now.


#6

I am having the same issue as of today 9AM EST. I am using the Twit node module and cannot receive tweets from the stream/filter.

I have restarted my machine and connection and still cannot receive information.

On the API monitoring tool it seems there is a connection issue: https://dev.twitter.com/overview/status


#7

I am still having this issue as of today 3:17pm EST


#8

Have you tried to use the curl command tool to verify this? You can find that tool under https://apps.twitter.com/ choose your app and then select TestOAuth, then choose the appropriate api that you want to test (eg: https://stream.twitter.com/1.1/statuses/sample.json) and then Get OAuth signature. It will give you a curl command to test in the terminal.


#10

The cURL command worked, but the node module does not. Do you know what could be the culprit?


#11

Probably some issue with the library you are using or how you are making the call. Hard to tell without looking at the code.


#12

It was working up until now. I have made a Github gist with the sample: https://gist.github.com/arlando/24078d06b2e3524297c5 there are no tweets being pushed back to the stream.


#13

Seems to be working now. Thank you all for your help.


#14

It’s still not working since last night. Nothing changed on our side. I am using Twitter’s hbc and the log shows:
New connection executed: hosebird-client-0, endpoint: /1.1/statuses/filter.json?delimited=length&stall_warnings=true
01/14 18:00:38 INFO [hosebird-client-io-thread-0] c.t.h.h.ClientBase - hosebird-client-0 Establishing a connection
01/14 18:00:39 WARN [hosebird-client-io-thread-0] c.t.h.h.ClientBase - hosebird-client-0 Error connecting w/ status code - 401, reason - Authorization Required


#15

I think it is related to set the filter level to Medium. it works again after we remove this.


#16

Same here, the client works normal when we removed the filter_level: medium option. Thanks.


#17

Confirmed. I removed the filter_level, and the stream is working now. I am using the node-twitter library. Can anyone confirm if it is the library or the API?


#18

I tried cURL with filter_level and it does not seem to respond with any tweets too. I am using track=google. When I remove filter_level on cURL it does work. The filter_level on the API seems to be breaking on any level that is not low. I have tried all levels. High and Medium are not responding.


#19

hello!

I’m getting strange thing that I’m unable to connect to twitter’s urls.api.twitter.com server from all my OVH IPs, seems like server is not responding to connections. Is something going on?


#20

can you clarify what you mean by “OVH IPs” - thanks


#21

What I had in mind was IP C blocks that belong to OVH, I have access to some addresses from different blocks and all of them are being blocked by twitter. (or so it seems)