Need to have images enabled for approved Summary Card


#1

I think that I indadvertedly marked the sensitive content checkbox when I requested Summary Card approval. Now that the Twitter Card is approved no images show appear. Please enable images. http://clinicalposters.com/news/2013/0520-twitter-cards-in-store.html


#2

Twitter support please respond and enable summary card images for my account. Thank you.