Need help! Twitter card is validating but not showing on Twitter


#1

Description of issue:

My URL seems to be working on Twitter Card validator, but I the cards are not working on twitter.

This is the message I get from the validator
INFO: Page fetched successfully
INFO: 32 metatags were found
INFO: twitter:card = summary_large_image tag found
INFO: Card loaded successfully
WARN: this card is redirected to http://oyepakistani.com/2018/02/10/levis-store-in-faisalabad-closed-for-having-hidden-cameras-in-womens-changing-rooms/

And it also shows the preview.

But on Twitter, it just comes with an image and a link in the tweet, not as a card!

URL affected (must be public):

Troubleshooting steps attempted [note that we will not prioritise posts unless there is evidence of following the troubleshooting guides]:


#2

Unable to reproduce. This link renders a card when posted.


#3

That was the link to the main website. Try this link


#4

Also working. Show me a link to a posted Tweet containing the URL that is not displaying a card.


#5

Ok so this is the link

And an attached screenshot shows how it is showing on twitter


#6

The screenshot does not show a Tweet with that link. It looks like th Tweets in your account have images attached already, so the card will never be displayed.


#7

So you mean to say that if I just post the tweet as a link, then it should show as a card?


#8

Yes, that is how it works.


#9

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.