Need assistance debugging Twitter Card


#1

I’ve read through several dozen threads on this topic here, but have not been able to resolve the issue. When I submit my page (as an example: http://axguidedtour.dynamics.com/en-us/guides/Gain%20immediate%20financial%20insights) to the Card Validator, I’m getting the “No Metatags Found” error.

Things I have tried, based on other threads:

Anyone have any insights as to why the card info isn’t showing up? I’ve tested using the complete set of Twitter metatags, and a combination of Twitter and OpenGraph metatags, with the same results. The validator just doesn’t seem to see any of the metatags.


#2

Hi,
Try these two things first then once implemented, we can check for other areas.

  1. Change the page name to not have spaces (%20). Just name it “gain-immediate-financial-insights”.
  2. Shorten the URL through bit.ly

I am not sure but the validator might not like spaces in the URL and I know that they recommend using a shortened link.


#3

I am also facing the same issue with my site:

But in your page shouldn’t the following metatag have site name rather @MSFTDynamics.
<meta name="twitter:site" content="**@MSFTDynamics**" />

Secondly, if after that also it doesn’t work. Then try using twitter:title and twitter:description, if that helps.


#4

Just wanted to close out this thread, for anyone coming along and reading it later. This issue appears to have resolved itself, and if you go to the URL listed above and share via Twitter, the Large Image Card now populates correctly. What I suspect happened was that twitter cached some bad metadata from an earlier test. Unfortunately, when this happens, it appears to take 1-2 weeks for it to clear out of the cache, making iterative experimentation and debugging extremely difficult, So be patient, and be very careful what metadata tags you use before having Twitter crawl your content! :slight_smile: