My tweets from Wordpress are truncated and Card Validator displays half of the cards


#1

Description of issue:
Hello :). My main problem is that my tweets from Wordpress are truncated and ended with three dots in Twitter. I use this plugins on my website about publish: Twitter Auto Publish and JM Twitter Cards. I have also changed recently my Wordpress theme and I don’t know how I can repair this problem :).

Second problem is that Card Validator for me does not show the whole card, only half.
Screen:

Someone can help me :)?

URL affected (must be public):

My website: http://consolezone.pl
URL from Card Validator: http://consolezone.pl/the-elder-scrolls-online-summerset-zapowiedziane-tajemnice-nowej-krainy-odkryjemy-5-czerwca/

Troubleshooting steps attempted [note that we will not prioritise posts unless there is evidence of following the troubleshooting guides]:


#2

I still need help :). I turned off the “JM Twitter Cards” plugin and added the following code to the functions.php file in my Wordpress theme :). But still cuts my Tweets from Wordpress.

function my_twitter_cards() {
    if (is_singular()) {
        global $post;
	$twitter_user = str_replace('@', 'ConsolezonePL', get_the_author_meta('twitter'));
	$twitter_url = get_permalink();
	$twitter_title = get_the_title();
	$twitter_excerpt = get_the_excerpt();
	$twittercard_image = wp_get_attachment_image_src(get_post_thumbnail_id($post->ID), 'full');
	$twittercard_thumb = $twittercard_image[0];
	if (!$twittercard_thumb) {
	    $twittercard_thumb = 'http://www.example.com/default-image.png';
	}
	if ($twitter_user) {
	    echo '<meta name="twitter:creator" value="@' . esc_attr($twitter_user) . '" />' . "\n";
	}
	echo '<meta name="twitter:card" value="summary_large_image" />' . "\n";
	echo '<meta name="twitter:url" value="' . esc_url($twitter_url) . '" />' . "\n";
	echo '<meta name="twitter:title" value="' . esc_attr($twitter_title) . '" />' . "\n";
	echo '<meta name="twitter:description" value="' . esc_attr($twitter_excerpt) . '" />' . "\n";
	echo '<meta name="twitter:image" value="' . esc_url($twittercard_thumb) . '" />' . "\n";
	echo '<meta name="twitter:site" value="@ConsolezonePL" />' . "\n";
	echo '<meta name="twitter:truncated" value="false" />' . "\n";
    }
}
add_action('wp_head', 'my_twitter_cards');

#3

My problem is solved :). I had to manually enter the character limit to 280 in the plugin “Twitter Auto Publish” :). I’ve seen this option before but apparently I did not check the result after the changes :).


#4