My phone is registered with my account but I can not create apps


#1

I am trying to create an app and it refuses with
Error
You must add your mobile phone to your Twitter profile before creating an application. I have the phone added and on and logged in and still get this error.
What am I doing wrong.

Thanks
Gary


#2

I am currently having this issue as well. My phone number is registered - I put the confirmation code in and received a text saying “Your phone is activated!”. I see the phone number listed under mobile in my account settings.

But EVERY TIME I try to create a new app, it still says “You must add your mobile phone to your Twitter profile before creating an application”. Did you ever resolve this?


#3

@andypiper Is this something that’s being worked on? Or have I missed something?


#4

I’m having the same issue and am disappointed there are no responses to this yet, especially since the original post was last year. Has anyone found a resolution?


#6

I am facing the same issue. Begrudgingly added my phone number and I still can’t create an application. Some reply from Twitter would be great.


#7

I am experiencing the same issue


#8

Same here. Really frustrated as I had to go out and get a phone with a text plan just to register this for a customer. 24 hours of time wasted where I can’t test API integration because twitter doesn’t recognize my number.

TWITTER IS NOW MY BLOCKER.


#9

I’m having the same problem. Is there any solution to this yet?


#10

Same Issue.
Twitter, do somethibng ASAP


#11

Another day & nothing has changed. Time to forget using Twitter & move to a different social media platform maybe. The MOST pathetic aspect is the LACK OF RESPONSE from Twitter staff. Seriously, if you can’t fix it, remove the need for it


#12

It is irritating if an amateur can spot there is a huge issue but the company doesn’t communiccate at all. Losing market share and you wonder why??? COMMUNICATION is core


#13

Having the same problem. Any ideas why we’re all having this problem? I’ve tried multiple phone numbers and restarted the process to create an application, multiple times.

This is holding me back, too.


#14

Just wanted to chime in and say I’m also having this problem. I followed the advice from the Twitter Staff here, and am waiting for new emails on the issue. If it helps, I’m on Android 4.1.2 on a Samsung-SGH-I437 (Galaxy Express).


#15

Hi everyone - apologies for this issue - I’ve just posted an update on the Announcements forum.


#16

As of 11:48 BST 23 June, this is still happening, at least for me. Still can’t create apps. Any word on when a fix might be in place?


#17

The latency issue remains at the moment, unfortunately. I’ve seen reports of some folks finding they are able to create apps anything between 3 and 24 hours after they associate a phone number. Be assured that this is an active issue for us and we are working towards a full resolution.