More Image Not Displaying


#1

Hi,

From looking through this support forum it seems to be a common issue with quite a few causes but I too am having issues getting images to display and have double checked all the troubleshooting tips.

My domain junkey.com is whitelisted for card type summary_large_image and using the Card Validator the following is logged:

INFO:  Page fetched successfully
INFO:  20 metatags were found
INFO:  twitter:card = summary_large_image tag found
INFO:  Card loaded successfully

An example link is https://junkey.com/item/17592186186054/yosemite

What I am seeing is the Title, Description etc are all loading but the image is not. I’ve tried a multitude of variations to try and get to the bottom of why it refuses to display.

From looking on various other online resources I’ve seen a bit of conflicting info on whether the image tage should be:

<meta name='twitter:image' content='image_url' />

or

<meta name='twitter:image:src' content='image_url' />

But I’ve tried both and still no joy.

I’ve checked the robots.txt, I’ve checked there’s no proxy issues, I’ve checked everything I can think of and have exhausted all avenues of investigation.

Can anyone help me?

Please…?

Thanks!

Adam


#2

The only thing I can see that looks incorrect at the moment is that you’re specifying a relative rather than an absolute path in the twitter:img:src tag. Have you tried it with a leading http: on the URL?


#3

I started out with an absolute path https://... which didn’t work. That is why I switched to the generic protocol //... which as stated above didn’t work also.

What you did remind me of was that I didn’t test non-SSL explicitly so I just tried explicitly adding http://... and guess what… Bingo!

So it seems Twitter is having issues loading images from a secure socket?

I wonder whether it was something to do with Twitter servers not having the (COMODO CA) root certificate installed? I would have thought it should have read that from the certificate chain I have installed?

I wonder how many of the the other “Image not displaying” issues are to do with this same reason.

Anyway, thanks for the help Andy!


#4

That’s interesting! I suppose the CA thing is one possible explanation, although I can’t verify it. I’ll see whether there’s any way to get our cards team to look at that but I’m not sure that it will be high on the list.

Glad you’re up-and-running!


#5

Hi @andypiper it was great going through the discussion, I came across with similar case in our application, and it seems it takes up absoulte URL’s only for twitter og images, is there a reason why we are only taking up absoulte url’s, rather relative URL’s must also be allowed perhaps ?

Thank You


#6

Our crawler only accepts absolute URLs.


#7

Thank you @andypiper will keep that in mind.


#8