MoPub requires ExoPlayer?

android

#1

MoPub upgrade from 3.x to 4.6.0

We’re building our project using a custom build system (so we’re using jars/compiling sources), nowhere on the wiki for mopub did I see a requirement for ExoPlayer or which version of exoplayer is required.

When I install the latest ExoPlayer (r1.5.7) is using android.media.PlaybackParams which requires a target to API level 23, which we currently do not support.

What is the version of ExoPlayer required for MoPub v4.6.0? Please update the documentation with all of the necessary libraries.


#2

You can target 22 but build with 23

compileSdkVersion 23
buildToolsVersion '23.0.3’
minSdkVersion 16 (or whatever you want)
targetSdkVersion 22

compile ‘com.google.android.exoplayer:exoplayer:r1.5.7’


#3

In the end I just grabbed the mopub and mopub volley jars from bintray, and then I didn’t have to worry about compiling exoplayer.

In our custom build system, it’s currently not possible to compile with and target different sdk versions.