mentions_timeline response problem API v1.1


#1

Hello,

today I have tried to implement mentions timeline API for ver 1.1 and after my authorized request:

https://api.twitter.com/1.1/statuses/mentions.json?count=10&trim_user=true&contributor_details=false&include_entities=false

I got response code 400; empty response body and headers was look like this: { date: ‘Thu, 06 Sep 2012 14:47:00 UTC’, server: ‘tfe’ }

Where is problem here? At my side?

I have also tried with this URL (there is bug on this page https://dev.twitter.com/docs/api/1.1/get/statuses/mentions_timeline). First it says to send request on https://api.twitter.com/1.1/statuses/mentions_timeline.json and after it says https://api.twitter.com/1.1/statuses/mentions.json

https://api.twitter.com/1.1/statuses/mentions_timeline.json?count=10&trim_user=true&contributor_details=false&include_entities=false


#2

You should indeed be using statuses/mentions_timeline.json – I’ve corrected the documentation error in the example portion of that doc.

Was there a status line with that HTTP response?


#3

Still the same…

Response code: 400
Request url: https://api.twitter.com/1.1/statuses/mentions_timeline.json?count=200&trim_user=true&contributor_details=false&include_entities=false

I have tried without URI parameters, to change count param… I dont know what to do. I really need this API endpoint!


#4

Are you sending authorization with the request?


#5

Same problem here (and yes, every request is authorized). I am using the 1.1 endpoint (statuses/mentions_timeline), supply with count=200 and similar details. Call returns zero results. I run it again, zero results. I run it again, all results there.

I ran this over a batch of users, and about every 7th or 8th user got successful results back on the first attempt.

@episod Similar to other issues, is the count size too large and the request times out on your side maybe?


#6

Same problem, I tried ‘statuses/mentions_timeline’ call with count=200 and it returns empty results. I am currently working with count=150 until the guys from Twitter fix this ‘count=200’ issue.


#7

I’m looking into a few issues with mentions timeline today. I’ll see if I can get a better understanding of this.


#8

When this happens, is it with your account specifically? If not, which account?


#9

When you say you get empty results, is this specifically an empty array, or is there a 502 with a non-JSON response you receive from this call?

Literal values of your HTTP response code and body would be helpful in tracking this down.


#10

while am using twitter mentiom url to download it return an error msg
{“errors”:[{“message”:“Bad Authentication data”,“code”:215}]}
this is my code
https://api.twitter.com/1.1/statuses/mentions_timeline.json?count=10&trim_user=true&contributor_details=false&include_entities=true&screenname=@preethi_69


#11

the @ symbol is not a valid character for the screen_name parameter – also, the mentions timeline doesn’t take a “screenname” nor “screen_name” parameter.


#12

I think, status/mentions_timeline is no more working… :frowning:

$connection->get(‘get/statuses/mentions_timeline’);
Returning:

stdClass Object ( [errors] => Array ( [0] => stdClass Object ( [message] => Sorry, that page does not exist [code] => 34 ) ) )


#13

You’re trying to access get/statuses/mentions_timeline instead of statuses/mentions_timeline :slight_smile:


#14

Helpful if a link to the 1.1 endpoint is put for 1/statuses/mentions … https://dev.twitter.com/docs/api/1/get/statuses/mentions