Media preview on timeline post not displaying image


#1

Looking at the two most recent posts on my test account here https://twitter.com/testingstuff244, the most recent preview image is a black placeholder image, whereas the second preview is properly previewing the correct image.

From what I can tell there isn’t any specific reason why the one would work and not the other. The card validator indicates everything is fine with both embeds and the meta tags for each are nearly the same.

What reasons might there be for the twitter:image meta tag to be ignored or is there any way to determine why the image didn’t work for the one tweet?


#2

That’s a funny one. It’s likely that our cache couldn’t fetch it (perhaps it tried before the thumbnail was generated?) and then left it as blank.

When I tweet that URL now, I get it:

Do you see the same?


#4

The working functionality seen on Jan 12 was after we deployed a fix. Before Jan. 9, 2015, we did not have an explicit allowance for the twitterbot in our robots txt file on our server and CDN. After that was deployed, things worked fine until just recently. If you take a look at the recent posts on the above test account, you’ll notice that they’re failing again.

The urls linked in the tweets validate fine with the twitter card validator. Any insight into why these thumbnails are not loading would be appreciated.


#5

Following up here after an outside discussion with @TCampaigne.

Are you guys still having trouble here? The latest player card test Tweet seems to be pulling in images ok now.