Manage Application Test OAuth sends to Access denied

oauth

#1

I have created an application a while ago, and everything was working fine
I have created another application recently and noticed that when I click Test OAuth send me to developers portal and displaying the message:

Access denied
You are not authorized to access this page.

I also cannot properly log in to dev portal. Whenever I click on sign in button, I am sent to my twitter account with which I am successfully authenticated. When I try to log to dev again, I get the same result
My old application also had stopped working. All my request are sent back with null return

Is anyone having the same problems?


#2

Hey @WariosiusAlenes Even i am facing the same problem. First i thought it would be because of call back URL but i was wrong. Please let me also know if u find any solution for the same.


#3

Hi @WariosiusAlenes, I have this too.

It is not possible to login to dev.twitter.com, if I click Test OAuth from apps.twitter.com it shows an ‘Access Denied’.

I also made a brand new account to check whether some account settings might produce this behavior, but the new account shows exactly the same symptoms.

Anything I can do? I’d like to work with the Twitter API and I need access for a study related assignment, but I can’t work with the system right now.


#4

We have an issue with signins not working on the dev.twitter.com site at the moment.

In the meantime, I would recommend that you look at using twurl to test any requests you need rather than attempting to use the OAuth Generator tool. There’s a tutorial available if you’re not familiar with that tool.

Access and signins to apps.twitter.com should be unaffected.


#5

Hi Andy!

Thanks a lot for your reply and the workaround.
Do you have any idea now when this problem will be resolved?


#6

No, I have nothing to share on an ETA for a fix - this is very low priority for us as the only reasons for that sign-in to work would be for the OAuth Generator, and there are workarounds available.


#7

Twurl is a nice tool, but it’s not really a workaround. I need to console test the Streaming API. Twurl only gives output now and then, and does not produce stable behavior.

What I do:

  • Authentication worked fine
  • twurl -H stream.twitter.com /1.1/statuses/sample.json sometimes gives a console output which (I assume) represents a live stream
  • The second time I run this exact command, nothing happens.

Besides, I haven’t found a way to capture the stream into a file. For standard API requests, the normal ‘> filename.file’ appendix works fine, but this results into an empty file for the twurl/Streaming API combo.

I hope this adds some priority to the issue.


#8

We are not likely to prioritise replacing this web based tool in the immediate future since workarounds exist.
Thank you for the input on the missing functionality. What would you like to see as an alternative?


#9

I’d like to see an alternative that is capable of capturing the twitter public stream for a few minutes, write it to the filesystem and give proper error messages when it can’t.

twurl only partially does this.

curl is hardly usable without the web based tool to generate oauth signings.


#10

Hi Andy!

I have the same problem to login to dev.twitter and see the tv api documentation. Do you have any idea if that will be fixed?

Thanks!


#11

I advise you to use twurl instead.


#12

Hi!

I need access to the TV API documentation at https://dev.twitter.com/rest/tv, for testing purposes I will use twurl but I need the documentation for this tests.

Thanks again!