Major trouble to get access to api.twitter.com (timeouts)

api

#1

Hello,

Starting 2 days ago (on the 21st of February) my service Threadreaderapp.com
got plenty of timeout errors while connecting to api.twitter.com
They comes in multiples flavours:

  • Failed to connect to api.twitter.com port 443: Connection timed out
  • Connection timed out after 20001 milliseconds
  • And a few other timeout errors

95% of any kind of API query will time out,
and as today it is still the case.

Three important information: first no code has changed between the moment it worked and now,
second every tool I tried to use to connect to Twitter (ping, nmap etc) works and give the server here and up, third the very same code will connect without any problem if I try it from another IP/machine

$ nmap -Pn -p 443 api.twitter.com
Nmap scan report for api.twitter.com (104.244.42.194)
Host is up (0.030s latency).
PORT    STATE SERVICE
443/tcp open  https
$ ping api.twitter.com
PING api.twitter.com (104.244.42.2) 56(84) bytes of data.
64 bytes from 104.244.42.2: icmp_seq=1 ttl=56 time=30.0 ms

Any idea? Is the IP/server blocked in someway?
Impossible to get in contact with Twitter so far

Thank you for your help