Linker command failed with exit code 1 (use -v to see invocation)


#1

I done your update and got this error,
i have opened terminal and ran rm -rf ~/Library/Caches/com.crashlytics.mac but get no update when i reopen fabric
still got this error please help :smile:


#2

@salty_adam had you quit Fabric.app before running that command?


#3

yes i have


#4


#5

also i have version 1.14.4 installed and I’m getting that error from when i installed 1.14.4


#6

@salty_adam Can you try removing Digits.framework from your app and from the “Link Binary with Libraries” build phase. Then re-add them through Fabric.app and let me know how it goes?


#7

yes but when i removed them all, i couldn’t readd them through the fabric app because my app won’t build


#8

Can you try this out? Run this command in terminal

ditto -xk ~/Library/Caches/com.crashlytics.mac/5b91b14e832a7b1c29441ec5ba109810/sdks/ios/com.digitskit.sdk.ios-default.zip ~/Desktop/

which will copy the framework to a blank folder in the desktop. You can then manually add that back into your project.


#9

okay I managed to fix the issue.
I removed all the frameworks and readded them as a new app and that seemed to work


#10

Glad to hear that did the trick @salty_adam and sorry for the inconvenience on this!


#11