Limit problem while connecting to API ( getusertimeline) with new usera


#1

Recently I realized that new twitter account while trying to connect to twitter API get limit rate error ( older works fine ).
Try create new twitter account,
next using some test application try for example get hometimeline - limit error, but on same app same IP older accounts works fine.
Thanks
Best regards


#2

This is from log:
08:55:29.561 ERROR m.s.l.s.TwitterService: 400:The request was invalid. An accom
panying error message will explain why. This is the status code that will be ret
urned during rate limiting (https://dev.twitter.com/pages/rate-limiting).
error - Rate limit exceeded. Clients may not make more than 350 requests per hou
r.
request - /1/statuses/user_timeline.json?include_rts=true&include_entities=true&
include_my_retweet=1&count=10&page=1

And still works good for my older twitter account, for newer one doesnt.
I checked in log if tokens are good but yes, new accounts has new tokens… Seems that problem is from server side.

Regards


#3

Are you using authentication? You’re using an outdated version of the API that will cease functioning on May 7, 2013. Be sure and upgrade to API v1.1. It looks like you’re being rate limited, but it’s hard to be absolutely sure because you’re sharing an error from a library rather than an error from the API itself. Are you monitoring your rate limits as you make requests? Are you sure you’re actually being thought of as authenticated and not just getting a loosey-goosey interpretation of your request? (API v1 is flexible with bad auth – if it can service your request in an unauthenticated context, it’ll try).


#4

Ok I got today new version of twitter4j ( 3.0.3 ) and same problem:
20:29:34.110 ERROR m.s.s.Twitter: 429:Returned in API v1.1 when a request cannot be served due to the application’s rate limit having been exhausted for the resource. See Rate Limiting in API v1.1.(https://dev.twitter.com/docs/rate-limiting/1.1)
message - Rate limit exceeded
code - 88

As You can see API 1.1, and same result my old user @daaatz wrks fine, new user @daaatzwp got limit problem.
And Im 100% sure that limit could not be reach. Because this account ( @daaatzwp ) was used only locally, there is only 1 tweet in this account, so I couldnt reach the limit.
I can here paste my code but generally it works like in: http://twitter4j.org/en/code-examples.html#oauth

Today I even switched to some my old branch from february and same thing ( on Feb it was working ).

Regards


#5

I think you’re being rate limited as expected. Are you monitoring how many actual API requests are being made using your access token?


#6

I cant be rate limited.
I’ll show You example:
I run my machine, create new twitter account, run my App locally, use this new account and when I want to get hometilne i get this rate limit error.
On the other hand, my old account works fine.
So there is no way that I’ve made 350 req for new twitter account…


#7

I checked again with other code ( code in Scala ):
val config = new twitter4j.conf.ConfigurationBuilder()
.setOAuthConsumerKey(Props.get(“twitter4j.oauth.consumerKey”).openOr(""))
.setOAuthConsumerSecret(Props.get(“twitter4j.oauth.consumerSecret”).openOr(""))
.setOAuthAccessToken(User.currentUser.get.twitterToken.is)
.setOAuthAccessTokenSecret(User.currentUser.get.twitterTokenSecret.is)
.build
logger.info(config)
val twitter = new TwitterFactory(config).getInstance
val statuses = twitter.getHomeTimeline(getPaging(1, “tweets.per.page”)).toArray.toList

and for old user it works fine, for newer one I have limit error - which cant be possible… I checked also with 2 others new users same thing, some my old account works fine…
I logged conf and access tokens etc are good. I can even paste You it but on @ ( secure ).

Thanks


#8

Hi checked once more, I’ve created new App: https://dev.twitter.com/apps
using consumerkeys and access tokens and code above works fine for new users but, it doesn work when I get access tokens from using https://api.twitter.com/oauth/access_token.
In my app it connecting on new consumerkeys for one of my old twitter accounts works fine, but for new no.


#9

I generated also new consumerKey and consumerSecret, and I’ve same result.
Seems that tokens which I get from request for some users are limited by default…


#10

Ah I coul listen to You at first and monitor calling to API…
One function just for some users was going into endless loop until got rate limit…
Thanks :wink:


#11

supported like


#12

ben sayfama gelen taleplerimi kabul edemiyorum ilgilenmenizi rica ediyorum…


#13

Rest Api e’ possibile amuntare i limiti di twitter4J.getFollowersList pagando o mensilmente o annualmente qualcosa a dev.twitter.com??