I've added the summary_card_large to our website but it does not show


#1

The image does not show up in the twitter stream… It used to be inconsistent but now it does not show up at all!

<meta name="twitter:app:name:googleplay" content="partyONN">
<meta name="twitter:app:url:googleplay" content="https://play.google.com/store/apps/details?id=com.konsoltcorp.partyONN">
<meta name="twitter:app:id:googleplay" content="com.konsoltcorp.partyONN">

For example: https://partyonn.me/social/533886d0a678cb884f668432

This URL redirects to https://partyonn.me/#/event/533886d0a678cb884f668432 which does not contain the meta tags.

This used to work, but now none of the cards that are posted from the website have the images displaying in the card!


#2

the URL parameter in the image url is dynamic and is appended to the image url on each page get


#3

Note: The Validator tool passes the url and previews it as expected.


#4

Hello,

I think the reason why your image is not appearing is because Twitterbot could not verify the access rights. Here is a solution for you.

  1. Use your S3 bucket as a subdomain to get control by reversing the URL:
    https://partyonn.s3.amazonaws.com/dae44640-b84e-11e3-8b88-3bc656965659.jpg?453243412

  2. Provide a robots.txt file on this subdomain to make sure Twitterbot can access your images:
    https://partyonn.s3.amazonaws.com/robots.txt

    User-agent: Twitterbot
    Allow: *

Please keep us posted but I’m confident this will solve your issues.


#5

Works beeeeaaaautifully! Thanks!