It's not loading data with the new method from tutorials

ios
fabric
twitterkit

#1

Hi,
I have twitter 2.0.2 version, and seems is not working with the new method that you have on your tutorials.
For example, with the first below code , it works without a problem, but with the second code it’s not loading data, it just a spinning wheel with tableview’s separate lines.

import UIKit import TwitterKit

class UserTimelineViewController: TWTRTimelineViewController { override func viewDidLoad() { super.viewDidLoad() let client = TWTRAPIClient() self.dataSource = TWTRUserTimelineDataSource(screenName: "fabric", APIClient: client) }

import UIKit import TwitterKit

class UserTimelineViewController: TWTRTimelineViewController { convenience init() { let client = TWTRAPIClient() let dataSource = TWTRUserTimelineDataSource(screenName: "fabric", APIClient: client) self.init(dataSource: dataSource) } }


#2

@JEK_ZZ Thanks for reaching out on this - can you please share the console output when data is not loading?


#3

There is no error on console, it runs without a problem but data not load , here is a screenshot below


#4

Sorry I wasn’t clear, I wasn’t looking specifically for errors, just the raw console output.


#5

Mine does the same with the new method but with the old method it crashes when i run and build on device but on simulator it works fine. Here is the crash report: *** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘*** setObjectForKey: object cannot be nil (key: urls)’

And the Crashlytics report gave back this information, if it helps : -[TWTRJSONValidator pruneDictionary:]


#6

@Karabo_PNE Can you share more info about the exception that you hit and what code you’re using?


#7

Here are the images of my project when the error occurs, weirdly this only occurs when I run it on my iPhone 4s iOS 8.4.1. Attachedalso is a snapshot of the Crashlytics report