It looks like someone already used the token information you provided


#1

I am using OAuth to login and tweet to a users twitter account from a native iOS app. I initially used my clients existing key and secret for this, which let me log on successfully, but the account was read only and so I was unable to post updates. They created a read/write account for me and I replaced the old key/secret with the new ones. Now when I try and log in, I get taken to a page with the following message:

"Woah there!

This page is no longer valid. It looks like someone already used the token information you provided. Please return to the site that sent you to this page and try again … it was probably an honest mistake."

What does this message mean, and how can I resolve the issue?

Regards

Emily


#2

Maybe you should LOG OUT then log in again! This happen to me if i stay logged in for long time and accidentally try to log in again without logging out. So try that.


#3

I’m having the same problem. I tried logging out and back in, and I still get the same error message


#4

Hello, I have the same problem and I don’t know how to fix that. I’ve tried to find some solutions by Google, but I haven’t found any result/solution.


#5

Hi Emily,

Make sure that you’ve got all the pieces correct and try again… Four separate strings are required to generate requests succesfully:

  • consumer key - AKA your API key, associated directly with the application
  • consumer secret - the secret part of your API key
  • access token/oauth_token - the string that represents a specific user in relation to an application
  • access token secret/oauth_token_secret - the secret part of the access token

The access token needs to belong to the specific app and be at the correct permission level for you to post. Verify all the values you are using and try again.


#6

Hello, I’m programming to set the OAUTH authorization and more by JSOAUTH, being the used code the following:

$(document).ready(function() { var options = { consumerKey: '{my consumer key}', consumerSecret: '{my consumer secret}' }; var requestParams; var accessParams;
var oauth = OAuth(options);

oauth.get('https://api.twitter.com/oauth/request_token',

    function(data) {
        console.dir(data);
        window.open('https://api.twitter.com/oauth/authorize?'+data.text);
        requestParams = data.text
    },

    function(data) { alert('darn'); console.dir(data) });

});

Regards


#7

hi, i got this error too even when i have logged out multiple times, reset my computer etc. i cant figure out whats wrong, since i did not do anything with my code. or did i get it wrong right from the start?

session_start(); require('twitter-async/twitteroauth.php');

// The TwitterOAuth instance
$twitteroauth = new TwitterOAuth(“fakekey”, “fakekey2”);
// Requesting authentication tokens, the parameter is the URL we will be redirected to
$request_token = $twitteroauth->getRequestToken(‘http://127.0.0.1/somepage.php’);

// Saving them into the session
$_SESSION[‘oauth_token’] = $request_token[‘oauth_token’];
$_SESSION[‘oauth_token_secret’] = $request_token[‘oauth_token_secret’];

$url = $twitteroauth->getAuthorizeURL($request_token[‘oauth_token’]);
header('Location: '. $url);

will appreciate any help. thanks for looking.


#8

if that’s exactly how your code looks like, then remove these curly brackets { }. your key should only be within single qoutations ’ ’ otherwise twitter wont read it. I had made the same mistake.
I hope it helps!


#9

Hello, but my keys are only within single quotations (I used brackets there to contain and explain using words).
Really, the part of the code which contains the keys is like this (keys within single quotations without brackets):

var oauth = OAuth({
consumerKey: ’ ',
consumerSecret: ’ ',
accessTokenKey: ’ ',
accessTokenSecret: ’ '
});

I need a quick answer to fix that.


#10

Same problem here from IOS. I reset the keys and that fixed it, for now. My first set of keys lasted all of an hour before they stopped working.

Note that when you reset the keys it takes a minute to display even if you reload.

Also, there appear to be two app management portals where you can view the status of your app

https://dev.twitter.com/

On the second site, some of the settings do not even get saved when you change them, wonderful. I don’t know if using one site or the other to manage your app contributes to token issues.


#11

Hello, I have tried to reset that but the problem continues. To see my JS OAUTH app code, please read my last answer (the second).


#12

I hit the same problem today. My apps on iOS and Android are working fine for months. I can still see customers posting on twitter today. However, today when I tried to logout and login again from my iOS app, I got the this problem. I am afraid to reset keys. Would that break my old customers?


#13

same problem here. I tried to create a new application and that one is working just fine. But the old one, no! And I have no idea why is not working, everything seems to be ok.


#14

Hello, I had this problem by jsOauth (JS library) because I run my app in a webbrowser, where jsOauth not works (it only works for extensions,…).
Regards


#15

I have completely cleared cookies and tokens, reset my consumer keys multiple times, even deleted and reinstalled the app, and still get the “woah there” screen on trying to log in.


#16

Thank


#17

I am also experiencing this issue. The exact same code works perfectly fine on pre-iOS 5 but when run on iOS 5 I get:

-1012 "The operation couldn’t be completed."
NSErrorFailingURLKey=http://twitter.com/oauth/access_token
NSErrorFailingURLStringKey=http://twitter.com/oauth/access_token
NSUnderlyingError=0x93cef20 “The operation couldn’t be completed.”

Debugging I have found that on iOS 5 the OAFetchData method fetchDataWithRequest:delegate:didFinishSelector:didFailSelector: is failing and because that class is private I can’t look inside to see why.


#18

I fixed this by changing http to https in the three urls in the initOAuthWithDelegate: method in SA_OAuthTwitterEngine.m. Solution is detailed at http://www.musicalgeometry.com/?p=1537


#19

when ever came this problem in ios i got it

Woah there!

This page is no longer valid. It looks like someone already used the token information you provided. Please return to the site that sent you to this page and try again … it was probably an honest mistake.

Turns out the fix for this was simple although it took some hunting down! The date/time on the server running the app had somehow become a day behind. Twitter checks the time sync when using the API, and if the client doesn’t have the correct time, it’ll report the above error.


#20

Hi All,

Me too getting the same problem as it works fine on localhost, bit when i try to run the same code on Server it generates the same error.

Whoa there!
There is no request token for this page. That’s the special key we need from applications asking to use your Twitter account. Please go back to the site or application that sent you here and try again; it was probably just a mistake.

I think wwe need ot create a different application for the live server, the only last twick i am able to see at this point of time.