Issue on Android with okhttp v2.5.0

android

#1

Hi, I’ve found an issue when I use TwitterKit and the version of okhttp 2.5.0 (latest at the time of the post). it doesn’t work and you can replicate the issue trying the following:

compile 'com.squareup.okhttp:okhttp:2.5.0’
compile(‘com.twitter.sdk.android:twitter:1.10.0@aar’) {
transitive = true;
exclude module: ‘okhttp’
}

I had to use the okhttp library reverting to version 2.3.0 in order to get it working. It’s explained here as well: https://github.com/twitter/twitter-kit-android/issues/24

My temporary solution is:

compile 'com.squareup.okhttp:okhttp:2.3.0’
compile(‘com.twitter.sdk.android:twitter:1.10.0@aar’) {
transitive = true;
exclude module: ‘okhttp’
}


#2

Thanks for posting your workaround of reverting to okhttp library 2.3.0 rather than the most current version 2.5.0. We are working on adopting 2.5.0 but for the time being this is the only workaround.

Thanks again! :smile:


#3