Issue #280: Not a valid URL format - when trying to create a new application


#1

This was reported 3/15 by another user, then resolved as “not an issue” with the request to be moved to a discussion.

It is still a problem. I have attempted to create a new application with multiple variations of valid, fully qualified urls – even going so far as to attempt “http://google.com” – and it is still rejected. If Google is not a valid website, I am not sure what qualifies! :slight_smile:


#2

Thanks for the report, Laura.

So we can understand the exact specifics here – can you retrace your steps:

You go to dev.twitter.com/apps you click on create an app… what exact data do you put in both the Website and Callback URL fields? (Both require explicit URLs, but you can leave callback URL blank). The website field is required.


#3

Let’s say i have these filled in, what’s wrong, why not a valid URL?
app name: sp1n3.tweetz

WebSite: http://sp1n3.com/

CallBack URL: sp1n3:/// (also tried sp1n3://callback, sp1n3:///callback)


#4

We will not accept non-HTTP or non-HTTPS URLs on the form on dev.twitter.com – you could use such custom URI schemes dynamically on the oauth/request_token step of OAuth, provided you place a HTTP or HTTPS based placeholder in this field.


#5

I’ve tried creating an app also and every single time, it tells me my URL isn’t valid. I’ve left it blank, I’ve tried it with http:// and I’ve tried it without http://. How do I resolve this?


#6

I am also having this issue with a regular http:// URL

HElp!


#7

iam also getting the same problem
Please resolve it fastly


#8

For people still having issues with this both your website and the callback url need “http://” in front. So this worked for me:

Website: http://example.com
Callback URL: http://example.com/auth/twitter/callback/
(the exact path is up to you)

Hope that helps!


#9

Just changed my browser from Firefox to IE9, the problem has been resolved.


#10

Guys I just figured it out I was having the same issue…If you say you that ur website is the same as the callback. When I copied and pasted my callback there was an extra space highlighted. That messed up the whole thing. Try checking that. When I did that it worked out great. It almost impossible to notice, but try re-copying and pasting and being very careful, that should do it.


#11

How can i set my localhost url while i am still in development phase? it does not accept urls like below.

http://localhost:12345
http://127.0.0.1:12345

Please help.


#12

would really like the solution for this . It’s very frustrating . You people don’t pay attention to the issues or what ?


#13

It seems like this problem just never goes. Getting sick of it.


#14

http://localhost is not working. How to set this?


#15

You cannot input “localhost” on the form itself. Use a publicly-accessible “placeholder” URL in this field and then use localhost as your explicit oauth_callback when actually working with the API.


#16

The caption says I can leave the callback URL field blank, yet when I click to create my application it says “Not a valid URL format.” How is this possible?


#17

Awesome, that was my issue. Well done, thanks for sharing.


#18

Have you filled in the other fields that are asking you for a URL?


#19

It helps me. Thanks


#20

That was my issue too! I can’t believe it. Was using chrome - kept getting the ‘invalid URL’ error message - changed to ie9 & it worked.