Is there any work being done to /search/tweets?


#1

Hi, today I am experiencing difficulties with REST Api for /search/tweets. For some reason when I try to search all English Tweets with content:
“Fallout 4” I get only up to 1400 results and later only single each time - what is really weird is that yesterday it worked without problem. I am using Twitter4j and retrieving only unique tweets by using maxID and ingoring retweets.

It always stops at the same MaxID:
730199081155440640
After setting this value to MaxID I constantly receive 1 tweet.

Edit: The same thing happens when I also include retweets.

Are there any maintance work or anything going on with REST Api for /search/tweets that may cause this kind of behaviour?


#2

I do not know if bumping is allowed - I tried to find information about that.

If not please remove this post and merge it with first one.

Anyway, it is still not working. Here is “minimal” code approach with Twitter4J that reproduces problem, I commented what needed to be commented and tried to keep everything simple so it should be readable

http://pastebin.com/kkCz9vGj
http://pastebin.com/kNXiyjPX

The problem, few days ago I was able to download 20 000 tweets without problem now it stops at around 4 000. I would really appreciate it if someone could take a look at it.