Is anyone else seeing increased 401 errors over the past 48 hours?


#1

We have been seeing significantly more 401 errors over the past 48 hours. Calls to account/verify_credentials succeed, but calls to statuses/mentions or statuses/direct_messages fail are failing with authentication errors.


#2

There’s a definite possibility of a rise in 401s right now; current working theory is that these are 500-series errors incorrectly being raised as 401s and we’re working to resolve that.


#3

Is there an open bug on this? We are having this issue across several of our client accounts. I can provide a set of reproducible steps if that would help you all to diagnose and fix the underlying issue.


#4

I’ve opened a bug for this that you can track. If there’s something deterministic you’ve found to cause the issue, please do let us know – we believe we’ve identified the problem and are working to fix it, but determinism isn’t a component to it from what I can tell.

Here’s the issue:
[issue:7920]


#5

I am having some 401 issues with streams: https://dev.twitter.com/discussions/7886


#6

Can we get an update on this bug?


#7

Hi,

I think I am currently experiencing this issue. All my GET requests (with 2 different app) to home_timeline, mentions result to a 401 response while POST requests like update works fine (with the same credentials)
Same weird behaviour with realtime API : userstream/user --> 401 but stream/filter --> 200

With another account (so other credentials), but on the same computer (& same app) all work fine.

Finally, looking at my users, today is the worst day with a lot of 401 responses on userstream/user ( 5 times more than yesterday ).

Please help.


#8

Any update on this?


#9

Hi folks,

I don’t yet have a more granular ETA as to when this issue will be fixed. We’re still working to resolve it. I’ll update the thread and the ticket when I have more information.

Thanks


#10

If you know, please tell me the conditions in which this problem occurs.
Because if this problem is not solved for several more weeks, I have to avoid this problem by a certain method.


#11

Hi all,

We’ve made some adjustments and think you should begin seeing these spurious 401s diminishing now. Let us know if you continue seeing the problems – we’ll hold out a bit before closing the ticket.

Thanks!


#12

This issue is as yet not been resolved.
There are reports from users of my clients.

Until the fix applied to all users take a long time?


#13

Same here … Still getting 401s for many users with valid authorization data (as they’ve just registered today).

Though, congrats on the architecture updates!


#14

Still getting 401s for many users with valid authorization data too.

Yesterday I had the problem with my own account for about 4 hours. Then without reauthorizing, it works, just ununderstandable.

I don’t know if it can help but here is the number of 401 event received from usertstream API (few of them may be due to bad token) : http://awesomescreenshot.com/0a46vlx21


#15

Thanks for the reports, we’re continuing to investigate.


#16

I’m also getting 401 errors seemingly randomly mixed with 200 codes for identical authorization data, in calls to user_timeline.


#17

A weird temporary fix for user is to Connect to www.twitter.com, Go on Settings, No change but just saved the settings --> At that point, the 401 errors disappear until the next occurrence.


#18

Thanks for the reports everyone. We’re still actively investigating these. All these details really help and we appreciate it.


#19

We are having these 401 issues also. Most of today.
Any time frame for a fix?


#20

Yes, I’m getting this problem (this account), with streaming. It started 2012-06-10 13:47:04 UTC, and all reconnects since have failed. I reset keys, but it did not help. If the 401 should be a 5xx error, I’m wondering what it could be, as it was working fine for the three days previous to the above, and nothing has been touched.
Incidentally I also tried clicking Recreate my access token, for this application, but the access token is not showing as changed (I’ve even logged out and back in, after 20+ minutes). Could that be related?