IP Blacklisted - No support form suits ticket filing


#1

We run about 15.000 customers (with many paying users) on our service and I keep a close eye on any rate-limit issues. I’m not sure if a script we are currently investigating was the issue, or a random IP/block type of auto-block. But today, our caching server (which we just made to take load off of Twitter’s API by caching our users’ most recent oembed responses) went black.

Our server is at: 176.28.55.37

curl --verbose “https://api.twitter.com/1/help/test.json

  • About to connect() to api.twitter.com port 443 (#0)
  • Trying 199.59.150.9… Connection timed out
  • Trying 199.59.149.232… Connection timed out
  • Trying 199.59.148.87… Connection timed out
  • couldn’t connect to host
  • Closing connection #0
    curl: (7) couldn’t connect to host

This works fine on my Mac at home, other API calls return data just fine. I ran a few tests on the server with non-Twitter URLs, all responded, the server is alive and healthy. It’s just Twitter that is not responding.

I tried to file a ticket with support, but none of the categories fit. I am struggling to keep my service up and running with our main server blocked, so I am happy to provide any details, shut anything down or check anything to resolve this asap.

Thanks.