iOS guest login fails, but occasionally has worked


#1

I have used Fabric to configure our iOS app. When we try to use the guest authentication like this:

[[Twitter sharedInstance] logInGuestWithCompletion:^(TWTRGuestSession *guestSession, NSError *error)

Sometimes it works, but usually we get the error:

“Your app may not be enabled for guest authentication. Please contact support@fabric.io to upgrade your consumer key.”

The Fabric app that was created during the process is: station: com.station-app.Station

We are running the app on an iPhone in debug mode, from xCode.

I have verified that the consumerKey and consumerSecret are set correctly. I have also tried a consumerKey and secret that i got from a twitter app I created on the dev site that wasn’t created by fabric. Same result either way.

There must be some trick I am missing.
-Jerry


#2

Did you get this sorted?


#3

Yes - we had to implement a login and retry so that if we aren’t able to get tweets with the session we started in appdelegate, then we do a new login and retry. That seems to work pretty well.

Thanks,
Jerry


#4

http://www.ioscodes.com/store/c1/Featured_Products.html


#5