iOS - error memory read failed for 0x0


#1

UPDATE: I was able to roll back my project to before the Fabric updates and am not experiencing the crash at app launch. I’ve tried updating Crashlytics and TwitterKit again but they continue to crash the app.

Yesterday I used the Fabric app to update both the TwitterKit and CrashlyticsKit associated with my XCode installation and iOS app.

Upon updating my app now crashes in the app delegate at the line used to initialize Fabric with an error stating: “error: memory read failed for 0x0”

It’s crashing on these lines:

[[Twitter sharedInstance] startWithConsumerKey:kTwitterConsumerKey consumerSecret:kTwitterConsumerSecret];
[Fabric with:@[[Twitter sharedInstance]]];

This has always worked for me and only changed since the updates to both kits yesterday. It is important to note that the app does not crash on iOS 7.1.2 and below. It crashes on iOS 8+.

Any assistance that can be provided on this would be greatly appreciated. We love the Fabric software we use and would like to continue using it. Thanks!

I’ve attached a screen of the stack trace during the crash.


#2