iOS Deep Links No Longer Working


#1

A while back I set up a Summary twitter card for testing deep linking into an app. I tested everything on the validator and applied with the domain and had everything working. Since the app I was testing with was not on the market, I used the google play and iOS ids of another app to test. Everything worked initially. The twitter card appeared when the link was posted and if the app was installed I could follow the link into the app. That was about a month ago.

Recently, I went back to update our code to use the 1.1 api and discovered that our twitter cards no longer worked on iOS. None of the previous posts or any new posts showed the “Get App” or “Open in App” options at the bottom anymore. They now appeared as if the meta tags for the app on iphone and ipad were not even present. I checked the posts on an Android device and the “Get App” option appeared correctly still. I then checked my page on the card validator again and its still approved.

I’m not entirely sure what changed behind the scenes, but heres the page with my meta tags just in case its something wrong with how I’m implementing the card: http://launchpad.appflighter.com/TwitterCard.html


#2

Do you have an example of a previous Tweet that is no longer showing the deeplinking or download links?


#3

Well, I hate to be that guy, but it appears that the issue is no longer occurring. I went back to post a tweet to an account that was not a shared testing account and the “Open in App” link was showing up again. Tested the deep links and all seems to be well again.

Only thing I changed was I removed “id” from in front of the iPhone and iPad id meta tags. May have just taken a while to propagate.

I have a test tweet on this account if you’re still interested in looking at it.