Ios app id not validating?


#1

Hi folks,

I can’t seem to get the validator tool fetching our iPhone App information [example src: http://xfactor.talktalk.co.uk/test.html]. The App is live and I have verified that the App ID is correct in both iTunes Connect and on the App Store [ID being 714091302 : https://itunes.apple.com/gb/app/talktalk-tv-time/id714091302].

When I submit the test.html page to the Validate & Apply tool [https://dev.twitter.com/docs/cards/validation/validator] it gives me the following error:
“Failed to fetch information for app with id 714091302”

I have also tried entering the id (714091302) on it’s own in the ‘try cards’ tab but to no avail.

Not sure where I’m going wrong? Any ideas?

Cheers,

P


#2

Can you try adding the literal “id” to the beginning of the id, as in “id 714091302”

This is consistent with the itunes URL: https://itunes.apple.com/gb/app/talktalk-tv-time/id714091302


#3

Hi,

I am also facing the same issue. Our App is on ios as well as Android. The app ids are 620435554 (Apple) and com.mize.myproducts (Android). I have tested it on Thursday for Android and was working inconsistently. From Friday onward I am always getting Unable Render Preview message. I also tried by adding id. There was no change. Can I any one know whether I am missing in thing in this regard.

Thanks in advance for the cooperation.


#4

Hi Suresh,

Can you provide a test URL I can try?

Thanks!


#5

Hi Ryan,

I tried prefixing the literal id “id714091302” but still no dice (same error):

http://xfactor.talktalk.co.uk/index.withios.html

Kind Regards,

Pete