iOS 11 - UIActivityViewController - Where is the 'Tweet' Button?

ios

#1

Hi all,

trying to understand what’s happening on the share window but I have no clue. Tweet button disappeared from the share dialog on iOS 11.

Using UIActivityViewController, with last Twitter iOS app installed.

This is the first state of the screen - still can add 1 character. No button visible

After adding more characters, button appears but on inactive state

If I tap on the place where button was supposed to be, tweet goes through, so button is there only “transparent”

What can I do to workaround this? Use TwitterKit?

Thanks,
Mário


#2

Someone from @TwitterStaff, Please reply to the above issue. In iOS 11 the Cancel and Tweet buttons are not by default visible while implemented through UIActivityViewController. Please provide a fix.


#3

Not wanting to sound too negative but I don’t think twitter has any iOS developers on board anymore. And/or iOS is low priority. Let’s just hope things get better. I am having similar troubles since iOS 11. Considering trying out twitter kit equivalent of tweet interface also.


#4

We also had same issue.
And now we solved the issue.
Our cause was common setting for UIBarButtonItem.

[[UIBarButtonItem appearance] setTitleTextAttributes:[NSDictionary dictionaryWithObjectsAndKeys:[UIColor whiteColor], UITextAttributeTextColor, [UIFont systemFontOfSize:16], UITextAttributeFont, nil] forState:UIControlStateNormal];

I think UITextAttributeTextColor from iOS 11 affects the UIBarButtonItem’s color of shared popup buttons like ‘Message’ or ‘Twitter’.

I just deleted [UIColor whiteColor], UITextAttributeTextColor this part. And solved this issue.
I hope this is helpful for you.