Invalid URI


#1

This is really weird. I am working on a plugin for some software (updating from v1 to v1.1, using Twitter4j for authentication). As a test, I tried to pull all updates from a user. I was using @TeamCoco for a while and everything worked perfectly. But then I tried to call another account, @Microsoft, and I got the following error:

Exception in thread “main” 404:The URI requested is invalid or the resource requested, such as a user, does not exists. Also returned when the requested format is not supported by the requested method.
message - Sorry, that page does not exist
code - 34

Relevant discussions can be found on the Internet at:
http://www.google.co.jp/search?q=66bcf48c or
http://www.google.co.jp/search?q=3d8e97bd
TwitterException{exceptionCode=[66bcf48c-3d8e97bd], statusCode=404, message=Sorry, that page does not exist, code=34, retryAfter=-1, rateLimitStatus=RateLimitStatusJSONImpl{remaining=179, limit=180, resetTimeInSeconds=1373558679, secondsUntilReset=898}, version=3.0.3}
at twitter4j.internal.http.HttpClientImpl.request(HttpClientImpl.java:177)
at twitter4j.internal.http.HttpClientWrapper.request(HttpClientWrapper.java:61)
at twitter4j.internal.http.HttpClientWrapper.get(HttpClientWrapper.java:81)
at twitter4j.TwitterImpl.get(TwitterImpl.java:1835)
at twitter4j.TwitterImpl.getUserListStatuses(TwitterImpl.java:1059)
at twitest.test.main(test.java:59)

I’ve tried 5-6 Twitter handles and I get the same error every time unless I use @TeamCoco.

What could cause this to happen? Also, I tried it before I left work yesterday and this morning with the same results…so I don’t think it is a rate limiting problem. I can provide code if necessary.


#2

Can you share more about how you’re formulating your request? Make sure you’re not including the “@” symbol when specifying values for parameters like screen_name.