Invalid image. This image cannot be fetched


#1

I am testing twitter card on card validator sometimes i am getting this error

Invalid image. This image cannot be fetched

Url i am using in twitter card validator :
http://dev.riktamtech.com/maventus/public/video.php?v=535

please have a look on this and reply as soon as possible


#2

““
Invalid image. This image cannot be fetched
””

I have same problem.
my test url : http://www.kkbox.com/tw/tc/mv/album-stage-1712545.html


#3

have anybody can answer me ?


#4

I am also receiving this error on accessible images.


#5

Sorry, our validator has been having intermittent issues. I submitted multiple times, and eventually got the image and everything appearing. Can you try again?


#6

"“
Timeout error. Fetching the image timed out.
”"
That is my new error, could you help us?
Or some thing I miss ?


#7

Image should be served by https.


#8

I have the same problem, but only with some images. E.g. http://t.co/Ug4rhkExOp
Are there maximum dimensions for the images, or requirements for ratio, or mandatory width and height meta tags in some circumstances? (this one is 615x338px)
Tried also this one with the validator, both with summary as well as with summary_large_image card type, and got the same results. Also https does not help, which is as per my understanding of the troubleshooting sections, also not required for my card types.
Thanks in advance.


#9

In the Validator for that URL, I see a timeout for the image. I’m not sure why – perhaps it’s not allowing requests from Twitterbot, or it takes too long to reply.

This can be complicated by caching on our side, where if we cache the card but not the image, the cache won’t be updated for 7 days.

You can learn more how to test and debug here: https://dev.twitter.com/docs/cards/troubleshooting#caching


#10

Thanks Ryan. Apparently the twitter bot is very friendly. Allowing the bot to index the particular directory solved the issue even if I would have expected that it accepts the explicit image path also when the containing directories itselves are declared not to be indexed in robots.txt.