Invalid Domain Pattern


#1

It appears I am having a similar problem as some other people but thought i’d start my own topic rather than hijack another one.

I am trying to get twitter cads for blog.carsforsale.com and I am able to get a preview when i put in the sample domain of Carsforsale.com Blog. However, it says I am not whitelisted. When I request approval for whitelisting, it gives me the error message of

*.blog.carsforsale.com whitelist request failed
ERROR: Invalid domain pattern

Is this because our @Carsforsalecom twitter handle has the main site www.carsforsale.com attached to is and not Blog.Carsforsale.com like I am trying to get whitelisted? Other than that I dont know why this error message is appearing


#2

I am also getting this domain pattern. When I validate a URL like:

https://ginatrapani.thinkup.com/?u=Gina+Trapani&n=facebook&d=2014-09-16&s=outreach_punchcard

I get the message:

*.ginatrapani.thinkup.com is not whitelisted

I would like to whitelist *.thinkup.com instead. Help?


#3

We’re experiencing the same error with the domain videos.mtb-news.de

*.videos.mtb-news.de whitelist request failed
ERROR: Invalid domain pattern

Maybe a sub-domain related issue?

Marcus


#4

Sorry for the inconvenience. I know we pushed a fix yesterday. When I submit to the validator, I now see this:

https://cards-dev.twitter.com/validator

Can you try and then submit? And if you already have, can you share a screen shot of the step/what you see?

Thanks!

Ryan


#5

Hi Ryan,

the preview of the card works fine:

https://dl.dropboxusercontent.com/s/aomhe519bk47bfj/2014-09-19%20at%2020.56.png?dl=0

But when I click “Request Approval” an error message appears immediately:

https://dl.dropboxusercontent.com/s/yzbsqjidh8j6wpy/2014-09-19%20at%2020.56%20%281%29.png?dl=0

(Sorry, as new user I’m not allowed to embed screenshots directly ;-))

Cheers, Marcus


#6

Thanks for getting back to me. When I run the validator, I get prompted to whitelist *.ginatrapani.thinkup.com. That doesn’t seem right, but I submit the request anyway. When I do, I get this error:

“*.ginatrapani.thinkup.com whitelist request failed
ERROR: Invalid domain pattern”


#7

Hi @rchoi - any hints?


#8

Apologies for the delay. We have a bug in our system that’s being worked through.

But I’ve manually updated; when I tweet, I now see this:

Just so you know, Cards only show when a tweet is expanded; you’ll need to click the “View summary” link to see it.

Thanks!


#9

Woohoo! thanks so much. Appreciate it.


#10

Of course. and Tremendously sorry about the delay!


#11

Hi Carsforsalecom,

I updated our site to whitelist. Sorry for the inconvenience.

FWIW, I didn’t see twitter Cards meta tags on any URLs; let me know if you have a specific URL I can help with.

Thanks!

Ryan


#12

@rchoi can we get the same workaround for us

basicly same bug effect.
"ERROR: Invalid domain pattern"

we have twitter cards on domain “chat.vive.me” and this is a showstopper for us atm.


#13

@rchoi I just updated https://andtheniwaslike.co and am now having the same bug, was wondering if I could it whitelisted.

Thanks!
Adam


#14

@rchoi - We’re having the same problem here at the Associated Press. Would you please whitelist bigstory.ap.org?

Thank you,
Kyle


#15

Sorry for the delay here. We’ve pushed a fix; can you try it again?

If it doesn’t work, can you reply here with the URL you’re submitting to the validator?

cards-dev.twitter.com/validator

Thanks!

Ryan


#16

Hi Matt and @mtbnews,

Sorry for the delay here. We’ve pushed a fix; can you try it again?

Thanks!

Ryan


#17

Hi Adam,

The validator is back on it’s feet. That said, it looks like you’re missing a twitter:image value.

Required meta tag missing (twitter:image)

Thanks!


#18

@rchoi I’m not getting the same message as you are.

Here’s what I see.

I see that twitter:image is missing from the root, but not from the (more important) url I’m testing (below). Anyway, I’m still seeing the “not whitelisted” error. I’m sharing https://andtheniwaslike.co/N_XJ8Q, but the validator is telling me “*.andtheniwaslike.co is not whitelisted” (as you can see, there isn’t a subdomain in the URL, and the domain has been validated in the past).


#19

Sorry for the trouble.

Can you humor me and try this URL in the tool?

https://www.andtheniwaslike.co/N_XJ8Q


#20

Just did. Same result as in the screenshot I linked to above. Only error I’m seeing is the “not whitelisted” error.