Invalid card type


#1

Hi, I’ve been trying to set up Twitter Cards but keep getting an Invalid Card Type when trying to validate and Apply.

I’m using WP SEO by Yoast and have activated the Twitter Cards in the social settings.

I’ve filled in all the required fields for the summary cards and every time I try to validate i’m told “invalid card type”. I get a preview on the Try Cards tab but when try to validate the preview isn’t displayed, just the message “unable to render card preview”.

Can anyone offer any advice please?

Barry


#2

9 weeks of waiting for a reply… 9 WEEKS


#3

Did you figure out what was wrong? I’m having a similar issue


#4

Same here


#5

Hi guys sorry for delay in my reply but as I wasn’t getting help here I unsubscribed from thread.

I now have them working. Go to the twitter cards again and select standard summary card, enter the details from one of your blog posts, filling the required fields.

When you go to validate and apply use the blog post URL and once validated you’ll see a link to valid your home page, click that.

It worked for me and I was approved within minutes after wards. :slight_smile:


#6

Sorry, replied below you comment. Pop back for how i resolved the issue with Twitter cards :slight_smile:


#7

I have and left a reply at bottom of thread.


#8

@barry_wells,

thanks for following up, and glad you got it working! (And thanks for helping others!)


#9

Hi, I was able to use twitter cards yesterday but its not working today. I get a “card type not found” error when I try to validate. please help.


#10

Was having the same problem and it was sorted when I added the blog post URL not the general website URL…Thanks for the help!


#11

Thanks for that update, @taranofal!


#12

I had some headaches getting this to work too. My site was in “coming soon” mode. I set it to ‘Live’ temporarily and all was well. It’s possible that the error was showing up because the Vailidator was not seeing the correct URL when it checked my site.


#13

Thank you @barry_wells…your method worked perfectly.


#14

Thanks a lot, adding any post’s link in the validate url field did the trick for me.