Invalid card type error


#1

At the moment we’ve tried a variety of things to get the validator to approve our markup. We can see clearly that the Twitterbot hits our URLs, but it doesn’t fetch the image specified in our markup and comes back and tells us that the card type is invalid.

If copy and paste our markup and drop it into a separate server, it works fine. On ours, it doesn’t. Both servers have the same robots.txt file.

Does the validator fetch images under a separate process that does not use the Twitterbot user agent? That’s the only thing that makes sense - our site only serves the Twitter card markup when we detect the Twitterbot user-agent. Of course in the static case above where it worked, there were no such user-agent exclusions.

Failing URL: http://favr.tt/view/oOOxWQkb/
Working URL: http://bedl.am/foo.html

Any help would be appreciated.

Geoffrey


#2

Can anyone at Twitter please comment on this?

It’s frustrating that we’ve spent almost 10x as much time trying to get Twitter Cards working than we spent on Facebook OG tags. Our Facebook integration has been working for weeks.