Internal Proxy Image Service Error


#1

Having problems validating gallery card.

Url is https://reflectera.com/share/7f48e52f11b100fbe830196ffefa8d9f
Images being served from S3->Cloudfront w/ SSL and custom domain configured through Route53.

Robots.txt file is https://eterna.reflectera.com/robots.txt

Please advise.


#2

I am also getting the same error and have the same config almost

EC2 -> Cloudfront with SSL

One of the url which is giving error
Webpage: https://hometriangle.com/photos/2/bathroom
Metatags:

<meta property="twitter:image0" content="https://static.hometriangle.com/imagecache/media/2916/htr-image-small-bathroom-390-2916.jpg?size=1200x630-3"/>
<meta property="twitter:image1" content="https://static.hometriangle.com/imagecache/media/3116/htr-image-geomatrix-411-3116.jpg?size=1200x630-3"/>
<meta property="twitter:image2" content="https://static.hometriangle.com/imagecache/media/2905/htr-image-small-bathroom-390-2905.jpg?size=1200x630-3"/>
<meta property="twitter:image3" content="https://static.hometriangle.com/imagecache/media/2914/htr-image-small-bathroom-390-2914.jpg?size=1200x630-3"/>

These cdn urls working fine on google and facebook. But getting issues on Twitter and Pinterest.


#3

Solved my problem.

There are three available urls in my scenario for the same image:
A. Custom domain url (i.e. https://mydomain.com/myimage.jpg
B. Cloudfront url (i.e. https://sjkljfkldafjs.cloudfront.net/myimage.jpg)
C. S3 url (https://mybucket.s3.amazonaws.com/myimage.jpg)

Option C is the only one that worked in my case.


#4

That’s not the solution but a work around. Still looking from answer from twitter - the reason for the issue.