Internal Error Code 131 where registering webhook

account-activity
error-131

#1

Hello, I am trying to register a webhook and when making the call the api returns me

{
  "errors": [
    {
      "message": "Internal error",
      "code": 131
    }
  ]
}

This is the call I’m making:
https://api.twitter.com/1.1/account_activity/all/ProductionEngage/webhooks.json?url=https://www.chrysalistest.com/php/php_pruebas/callback_twitter.php

I am doing something wrong?

Thank you.


#2

Hi,

Just wanted to check in here. Are you still experiencing this error? Have you tried any different webhook URLs?

Thanks!

Jessica


#3

Hi, yes i’m still experiencing this error.
I don`t have tried different webhook URL because this is the only one that i have.

But if this error is for my url should not I return an error of the documented ones like for example that the CRC is not correct?

Thank you


#4

Yes that is strange. I’m going to go ahead and have some our folks look into this issue and let you know if I hear anything further here.


#9

Hi @TestChrysalis - when I call your webhook URL with a crc_token parameter, I’m not seeing any evidence that a valid JSON response is being returned. I agree with you that seeing error 131 is not what you might expect if the CRC response is not valid, but can you check that your webhook is operating as expected?


#10

Hi, i have made this call:
https://www.chrysalistest.com/php/php_pruebas/callback_twitter.php?crc_token=1234567

and my webhook URL returns this JSON:
{
response_token: “sha256=3aaf380b7085eb585748beeccc628518e73b2e472d1d59f2f46d45f2586df098”
}

Thank you.


#11

Now that this is responding, are you also seeing the same 131 error on attempts to register the webhook?


#12

Yes


#13

Are you able to provide the full curl (or similar) command you’re using?