Incorrect metadata displayed for tweeted link / summary card


#1

Exactly the same issue as @ginatrapani highlighted here: Summary Large Image Card displaying incorrect data

Our client posts links to their content, such as http://www.contiki.com/six-two/these-three-little-letters-could-change-your-life/. The metadata returned is entirely different, although when clicked on it goes to the correct URL. See this tweet.

I have gone through the cards troubleshooting FAQ. I’ve checked the metadata; we are running WordPress, and have had Yoast SEO’s support team confirm the metadata is correct. We have checked robots files for origin servers, CDNs, etc. Twitterbot’s new IP ranges have been whitelisted with WP Engine and with CDNs.

The validator is returning either a redirect error or - often with the same URL - returning as “correct” but showing incorrect metadata, as with the above linked tweet. I have CURL’d, including as Twitterbot, various URLs from various locations around the world; we get 200 OK with no redirects involved and grep showing twitter metadata is present and correct.

I am at a loss as to why this is happening, and would appreciate some support.


#2

Thanks - unfortunately I don’t think we got to the bottom of the problem @ginatrapani was reporting as they took down the markup due to the issue, which is understandable but prevented us from debugging.

I’m going to ask our cards folks to take a look at this for you - I apologise for the problem you’re experiencing, there’s clearly something very odd happening here.


#3

(also just to confirm that I’ve followed the same debugging that you have, and indeed see that everything looks sound… so there’s clearly something else at play)


#4

Hi! I worked with WP Engine to debug this and it turned out it was a bug in their GeoIP plugin, which has been fixed since. Are you using that plugin? If you disable it, does this still happen?


#5

@andypiper Thank you for getting back to me so quickly. If you could ask the Cards guys to take a look, that’d be great. If they’d like to chat or require any more info, our number is 0118 391 3910.

Saying that…

@ginatrapani Yes, we are using the GeoIP plugin! I’ve just tried deactivating it and pasting a link, and tried the validator. No joy :disappointed: Would you mind putting me in contact with whomever you were speaking to at WPE?
(thanks also for replying to me on Twitter)


#6

I just filed a ticket with their tech support – when you do the same reference my ticket, they should know how to resolve it.


#7

OK cool this is interesting stuff. Thanks @ginatrapani for sharing more on what you’d done to resolve, appreciate it!


#8

Superb, thank you both. I’ll get on to WP Engine and post back here.


#9

I’ve sorted this out with WP Engine. It was Varnish:

“Basically Varnish, our caching layer, was losing the hash to look up the cached page by. This was due to too many headers being passed to varnish. When too many headers were being passed it was causing our platform to return a random page. Which is why the page would pull bad meta information. We just upped the value in varnish to allow for more headers to be sent.”

@ginatrapani’s ticket for the same error was closed last Tuesday (Nov. 29th). The fix was then pushed to WPE’s network on Friday Dec. 2nd, which is when I reported the issue. But the fix was deployed after I had done all my testing, so I didn’t see the new results.

I’ve tested some tweets - see our testing account at https://twitter.com/StudioTeamWP. New tweets are returning correct metadata, but old tweets are still likely to show incorrect metadata.

Thanks both for your help in resolving this :grinning:


#10

Perfect. Thanks for chasing this down and for the detailed explanation and follow-up here - hopefully that will help anyone else / potentially help us to rule out similar issues in the future.


#11

Hi there, I’ve had the same issue but using Squarespace and no luck with fixing it. Everything seems to be in place for the Summary Card with large image but the image and summary descriptions metadata always links to the example one from @nytimes:

<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@nytimes">
<meta name="twitter:creator" content="@SarahMaslinNir">
<meta name="twitter:title" content="Parade of Fans for Houston’s Funeral">
<meta name="twitter:description" content="NEWARK - The guest list and parade of limousines with celebrities emerging from them seemed more suited to a red carpet event in Hollywood or New York than than a gritty stretch of Sussex Avenue near the former site of the James M. Baxter Terrace public housing project here.">
<meta name="twitter:image" content="http://graphics8.nytimes.com/images/2012/02/19/us/19whitney-span/19whitney-span-articleLarge.jpg">

Please help?


#12

Hey @kunakirwa, I suggest you speak to Squarespace about their caching, as I did with WP Engine.


#13

Thanks @mattradford I will give that a try. The frustration is killing me :frowning:


#14

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.