in_reply_to_status_id is always null


#1

I’m having an issue getting in_reply_to_status_id to work currently. I’ve also tried the same code with in_reply_to_status_id_str and there is no difference.

My code is as follows:
$parameters = array(‘status’ => $enteredTweet, ‘in_reply_to_status_id’ => $enteredTweetID);
$status = $connection->post(‘statuses/update’, $parameters);

The result is that I post a tweet which has a null value for in_reply_to_status_id, but has the correct values for: in_reply_to_user_id, in_reply_to_screen_name, and in_reply_to_user_id_str.

Also, all of my $enteredTweet values begin with the @name of the sender of the original tweet I am trying to respond to. Is there a certain way this text must be formatted, or does it need any parameters? For example I am passing an $enteredTweet of “@scottluptowski hello” as a string value.

Thanks!


#2

Exactly the same thing I’m facing!!
Here’s what Twitter API JSON is returning me when reply is successfully posted

"id_str" = 337918014110433281;
“in_reply_to_screen_name” = geochirpr;
“in_reply_to_status_id” = “”;
“in_reply_to_status_id_str” = “”;
“in_reply_to_user_id” = 1378947649;
“in_reply_to_user_id_str” = 1378947649;

As you can see in reply to “in_reply_to_user_id” is populated but funnily enough,“in_reply_to_status_id” remains null. Even though I pass the “in_reply_to_status_id” parameters also I’ve included the @username. Still wouldnt work!!!

@scottluptowski did you ever find your way out?


#3

This issue is buggin me too! Anyone found a solution to this?


#4

I also found the same bug. In trying to answer a status of an account without protection enabled. All fields are filled as shown in the documentation, but the response has been nil in_reply_to_status_id field and generates no conversation.
:frowning: Hey Twitter please help us!


#5

Hi I actually managed to work it out myself long time back Stupid of me not checking this post up until now.

Heres what I did. I fetched the “id_str” of the tweet I want to reply to. And while composing the reply parameter I passed the already fetched “id_str” as an object for key “in_reply_to_status_id”. I believe previously I was fetching the “id” and passing to “in_reply_to_status_id” it dint work… Where as fetching “id_str” and passing to “in_reply_to_status_id” worked.

I hope it works for you as well. If it doesnt lemme know. Will be glad to help you :slight_smile:


#6

Hi I just updated the post. Please check the reply I sent to @LiquidServe. Lemme know if it still doesnt works out for ya. Will be glad to help!


#7

I am running in the exact problem described here, even though I am fetching “id_str” field and passing it to “in_reply_to_status_id” as suggested by @asharpvan and in many other forums. (And yes I am also mentioning the @user whom I am replying in the tweet text.)

Actually, in my many tests, it worked once or twice, but it is usually not working, so it is a mystery to me. I wonder if it might have something to do with retweets… i.e., whether to reply a retweet one must mention not only the user who retweeted but also the author of the retweeted post?


#8

Hmmm thats wierd @KinseyReporter!! If you havent still figured it out… Could you send me the code. I’d be glad to go through it for ya. email is sahpranav1712@gmail.com.

Cheers!!


#9

Yes that’s what I’m doing.
But it does not work.
The post is done, but when I capture the information tweet via API, the field is null in_reply_status_id.