Images show on certain cards and not others


#1

Hi, I’m not sure whats wrong with my website. Certain pages are showing images while others aren’t. My domain is whitelisted. The console shows this everytime: (no errors)

INFO: Page fetched successfully
INFO: 16 metatags were found
INFO: twitter:card = summary tag found
INFO: Card loaded successfully

http://taylorbentertainment.com/home/frassman/ this link is missing the image and shows a twitter placeholder
http://taylorbentertainment.com/home/b-hype/ this link shows the image perfectly.

I’m having the issue on a few pages on my site. I’ve tried adding hashtags to the end of url’s. Running through bit.ly and other url shorteners, reuploading images to my site, using smaller image sizes.

Thanks in advance.


#2

Is this still an issue for you? We had a temporary issue for a few days fetching some card images, but both of those links look ok for me at this point.


#3

Hi, I’m still having the issue. It looks like the top link is fine now but I’m still seeing the placeholder on other pages’ cards.

These pages specifically still aren’t showing the image.
http://taylorbentertainment.com/home/b-hype/
http://taylorbentertainment.com/home/linguakat/

My Card validator log is the same as my original post


#4

I’m having the exact same problem. All pages were working fine before, but now, some work and some don’t. I get the placeholder for the image. One other problem is that a page I just created (http://www.gooutsidebook.com/articles/coltsville-rampant-colt-moon.html) has the summary_large_image tag, but the validator shows a preview with a summary card (not large), again with just a placeholder image.


#5

We’re having the same problem. All pages were working fine before but since 2-3 weeks,no image is showing
These are results of testing on Card Validator (any pages)
INFO: Page fetched successfully
INFO: metatags were found
INFO: twitter:card = summary_large_image tag found
INFO: Card loaded successfully


#6

The first one works for me. The second one has a space in the URL for the image, which may be confusing the validator. Otherwise I can’t see an issue with the markup.

@GoOutsideBook I’m a bit baffled by this one. It looks like the tags are all correct and I can’t pin this down to the other problems I’ve seen. Did you change from a summary card to a summary_large_image recently?

@UrbanNetworkUK We can’t help without seeing an example URL.


#8

These pages aren’t showing the image


This works last week but no longer showing image when testing today


Thanks!


#9

Access to your images is blocked by your robots.txt file (this applies to your homepage as well, incidentally). This is covered in our troubleshooting documentation. I’m surprised it worked previously, assuming there have been no changes on your side.


#10

For http://www.gooutsidebook.com/articles/coltsville-rampant-colt-moon.html, which is the last page I created, I never used the summary card, only the summary_large_image. I created the page by copying http://www.gooutsidebook.com/articles/east-rock-angel-of-peace-statue-moon.html, which has the summary_large_image card. That page has the originally posted problem; it was working before but now the image is not displayed.

The second-to-last page I created, in July, (http://www.gooutsidebook.com/articles/bushnell-park-angel-moon.html) works properly.

The third-to-last page I created, in July, (http://www.gooutsidebook.com/articles/enfield-fireworks.html) has the posted problem.

The only odd thing that happened to the website recently is that I edited the .htaccess file to prevent referrer spam, and I made an editing mistake. A couple hours later, I got a Forbidden 403 error when I tried going to my site. I immediately fixed it and everything was fine, but I suppose the Twitterbot could have visited during that time. I’m not sure if that could be related in any way, or if that’s just a coincidence.


#11

I’m recently having this issue also on our Wordpress site. The images on the summary card and large image card don’t display either the intended image or the fallback image. This happened today on 2 out of 2 cards. Then about 3 hours later, I checked my feed and the images were displaying.

I’ve had the cards working perfectly for about 6 months and then within the last two weeks started seeing this issue. If I test my URLs in the validator there is no error message displayed, everything appears to be okay, but the image doesn’t display in the card preview either.

Even cards that had displayed as intended, if I retweet them now, don’t display the images properly.

It seems like there is a lag in getting the images loaded. Cards that were tweeted yesterday showed no image but today show the image. Also cards that were tweeted this morning showed no images for a couple hours and now are showing the image. Only one of my cards from today that posted 2 hours ago still shows no image.


#12

We cannot assist without example URLs that exhibit this issue.


#13

Thanks for the response.

I hesitated to include example URLs because as I said, the problem seems to go away after a few hours. So most likely the examples will appear to be working by the time anyone reads this.


I tried to post links but I’m getting an error message that “New users can only post 5 links” apparently each card contains several links. I’ll post the links below, separately.


#14

Posting the links…

This card is not currently displaying the image

Here is a card from June referencing the same blog page, but the image is working (granted, they are different types of cards)

Here is another post from today (30 mins ago) where the image is not working

Here is a summary card from today that is showing the image now but was not showing the image earlier today (in twitter feed)

I appreciate you taking the time to check this out. If you look through our feed, you can see that we use cards very often and haven’t had the problem until recently. Profile is ccpipeline


#15

Here’s one more card that is not working from today

And another card from July referencing the same URL that is displaying the image

UPDATE…
24 hours later, all of the cards that were not displaying images (linked to in my posts above) are now displaying images properly without any changes on my end.


#16

Sorry for the inconvenience, and glad to hear things are working again. We did make some changes about a week ago that caused a few issues, but it seems like the crawler is revisiting most of the affected sites and things are settling down again.


#17

Everything here seems to be working now.


#18

Great! sorry for the temporary inconvenience.


#19

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.