Images not showing up on summary cards


#1

Images aren’t showing up on our summary cards. The validator says the image is valid, but the image also doesn’t show up on the sample card on the validator. The image link is valid.

Here’s the URL: https://neighborland.com/ideas/mtv-more-bike-share-stations

Here’s a tweet with that URL: https://twitter.com/jacobsenscott/status/377534944467091457

Here’s the image url: https://d30wms7jgjmff8.cloudfront.net/assets/neighborland_fb-2c301fa338540d44ae769d2524d75944.jpg

Any idea what’s going on?


#2

Same problem here! Any Ideas?


#3

Yep, got this issue too:
URL: http://www.fotofonia.it/fotostoria-taking-my-time/
Tweet: https://twitter.com/fotOfonia/status/378277898731261952

Maybe twitter:cards don’t like CDNs…


#4

Yeah, i have same issue https://twitter.com/testspeakphone/status/380595462283071488


#5

I am also having the same issue. It says there is a timeout fetching the image in the card validator.

URL: http://www.whatshappen.in/events/697
Tweet: https://twitter.com/officeslag/status/380105068206252034
Image URL: http://api.whatshappen.in:2718/uploads/featured_event_poster/image/14/details_thumb_tauk.jpeg

I noticed that the name attribute for the image is “twitter:image” in the documentation, but in the Card Validation Tool, the attribute is “twitter:image:src”. Thanks!


#6

In my case I think the issue was with the robots.txt on our cdn. We forbid all robots from crawling our CDN. We only want them to crawl our site. But twitterbot checks the robots.txt before grabbing the image. I added

User-agent: Twitterbot
Disallow:

to robots.txt on the CDN and things are working.


#7

We are having the same issue with summary_large_image layout as well. Validator says OK, but twitter is not showing pics.

This happens from time to time: some other days things go ok. Its certainly not a missconfiguration issue, but I would really like to know what can be done. Twitter is the ONLY platform we are having this issues.


#8

Same issue here. And btw, looking at this thread, it does not display a SINGLE user picture! The only images displayed here are these werid eggs that are used when somebody does not have pic.

There does seem to be an issue on Twitter’s side, then?


#9

What I meant, it shows the “broken image” icon for when an image fails to load. And since it might bear on the topic, Chrome just told me the following errors in the console:

Failed to load resource: the server responded with a status of 403 (Forbidden) https://si0.twimg.com/profile_images/378800000115740414/fffcf94442237c785f5dcccc76487814_normal.png
Failed to load resource: the server responded with a status of 404 (Not Found) https://pbs.twimg.com/profile_images/378800000819482605/5756dadb0cac22b3daadbf08c2449ad9_normal.png
Failed to load resource: the server responded with a status of 403 (Forbidden) https://si0.twimg.com/profile_images/2984535046/0a230ccc7cba6e96235083292fb5a182_normal.jpeg
Failed to load resource: the server responded with a status of 503 (Site over allowed capacity.)

I would really appreciate it if somebody could give me a hint what’s going on before wasting more time trying to debug my own side.


#10

My twitter card image is not being displayed.

Here is my code. Can somebody help me please?

<meta name="twitter:title" content="{{page_title}}" />
<meta name="twitter:domain" content="http://www.fitwirr.com/">
<meta name="twitter:description" content="{{meta_description}}" />
<meta name="twitter:card" content="summary_large_image">
  <meta name="twitter:creator" content="@fitiwrr">
  
  <meta name="twitter:site" content="article">    
<meta name="twitter:image:width" content="610">
  <meta name="twitter:image:height" content="610">

#11

Can you provide an example URL?


#12

Thanks for this reply. This was exactly it.

More info for anyone who has the same problem:

https://dev.twitter.com/docs/cards/troubleshooting#robots


#13

Sorry for this. Have you tried:

https://dev.twitter.com/docs/cards/troubleshooting#robots


#14

I also got the same problem with images not showing up

Url: https://wishdrum.com/dev/drum/twttr/11OVCWh8ccLqWMQdCKDKxufV8Tv

Media: https://media.wishdrum.com/user-generated/development/drum/11OVCWh8ccLqWMQdCKDKxufV8Tv

Tweet: https://twitter.com/johdoesh11/status/499475023565172737


#15

I cannot access the first URL without being prompted for a login - so I suspect your content is not accessible to the Twitter crawler.


#16

Sorry for the late answer - was on holidays.

If you switch the ‘twitterbot’ as user-agent you should get the content back; when testing the card I get all information displayed but just the image is not showing up.

As we have cleared our database you need to use the following URLs instead:

URL: https://wishdrum.com/dev/drum/twttr/OESLRqHMVpsYQw0U1p0R9Ztasa1

Media: https://media.wishdrum.com/user-generated/development/drum/OESLRqHMVpsYQw0U1p0R9Ztasa1


#17

Hi guys, same problem here.

The validator shows our pretty image.

But this tweet shows only text. https://twitter.com/john_fisherman/status/505403952788430848

We have this active also for blog.memeoirs.com.

Help!


#18

The tweet you linked to properly displays the card for me.


#19

It displays the card, yes, but the image is missing.

That’s the whole conundrum. Any ideas?


#20

Hi! My twitter account (https://twitter.com/startfreshhome) has been approved for summary cards, however, when I run my URLs through the validator it says everything is working as expected, yet a thumbnail image isn’t showing up. Neither the validator nor an actual tweet will show the image.

My blog (http://blog.newhomesource.com/) is run through Wordpress. I’m not sure how I can verify if there is a robots.txt file blocking my images, and if so, how I can change that.

Using this blog as an example (http://blog.newhomesource.com/2014/10/first-home-every-new-homeowner-needs-master-bedroom/) the photo properties are 447 pixels x 292 pixels, 96 dpi, 47.8KB, Is there something wrong with the photo itself?

Any guidance would be much appreciated! Thanks!