Image not showing


From last week, the images are not getting displayed when we tweet even though we have the twitter image meta tag and the card validator returns the following,

twitter:card = summary_large_image tag found
INFO: Card loaded successfully

But the image is not getting loaded. The image size is within limits as well.
Here is the URL that we tested,

Any help on this would be appreciated.



Hi Any updates on this? I tried switching the summary_large_image to summary and also tried twitter:image:src instead of twitter:image. But nothing helped. We are not blocking twitter bot as well. Not sure why images are not showing up suddenly.



twitter:image is the correct syntax.

It looks like there is an SSL configuration issue with the domain that is serving the image (SSL Labs is giving it an F rating and it is vulnerable to various issues) so the crawler can’t fetch the image. You could try serving the image from another domain.


Hi Andy,

Thanks for the reply. We did a patch update and tried testing the images from the domain in the SSL labs and now it is returning C. After getting the score as C, I tried testing but still, the images are not showing up. So what is the score that we need to look for?



In the last week or so I have tried to get the twitter share button to post the image without any luck. It is now validating for both Facebook and Twitter yet my one remaining issue is the Twitter image not posting under the Twitter card type summary_large_image. Based on this thread I ran the staging address through the SSL report and got an F. I then ran the production address through the SSL report and got an A. I have not tried to put this or a prototype on the production server yet buy am starting to think it may work on the production server with a vastly better score. If anybody has any further information about this issue or how to resolve or what score one might need for the SSL configuration to no longer be an issue please forward that information? Thank you!



We’re unable to help without seeing a publically accessible link. It’s not the score necessarily that causes an issue here, but the server needs to support modern SSL/TLS crypto ciphers (and not be vulnerable to known attacks like POODLE, for instance), and also have a matching servername as the certificate. There’s more in the troubleshooting post. Note that if your images are hosted on a different domain to the link and page you’re sharing in a Tweet, that server will also need to conform to those same rules.


Hi Andy,

Thanks for the reply. Our server runs Windows 2008 (not R2) so it supports only TLS version 1.0 and not 1.1 or 1.2. And a publically available link would be any image on that server, like:

Is the TLS version supported sufficient or should we move towards higher ones?


You are going to have to move to a higher version of TLS for this to work.


Thank you Andy. I finally got the Twitter image to post. We did update the staging server such that it is now getting an A versus an F but ultimately I believe the problem we had was tweeting the image URL versus the URL of the page. Apparently Twitter reads the twitter:image after parsing the HTML in the page. I actually think this would be a good point to add to the troubleshooting list because there seems to be a lot of posts and threads that have misleading information on this aspect of sharing an image in the tweet.


closed #10

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.