Image not showing when posted in twitter


#1

I use the card validator to validate my url but the preview is not showing my image. There is no error at all. Can someone help ? My url is : https://www.youth.sg/Spotted/People/2017/4/Swimming-her-way-to-the-Miss-Mermaid-crown#.WP8p5VFGxVI.twitter


#2

The log for the card validator shown
INFO: Page fetched successfully
INFO: 21 metatags were found
INFO: twitter:card = summary_large_image tag found
INFO: Card loaded successfully

Urgently need assistance.


#3

Did you check the troubleshooting steps? That sounds like your image is the wrong size or that the cards crawler cannot read it.


#4

Hi Andy,
It used to work . I only change the twitter:card from
content=“summary” to “summary_large_image”

All my previous images in the Twitter that used to work are not working.

All my meta tags are accessible:

<meta name="twitter:card" content="summary_large_image"/>
<meta name="twitter:site" content="@youthsg"/>
<meta name="twitter:creator" content="@youthsg"/>
<meta name="twitter:title" content="Swimming her way to the Miss Mermaid crown"/>
<meta name="twitter:description" content="Meet Audrey Chen, Singapore's very own Little Mermaid."/>
<meta name="twitter:image" content="https://www.youth.sg/~/media/YouthSG/Swimming-her-way-to-the-Miss-Mermaid-crown/banner-audrey-chen-monofin-pose-nemo-mermaid.ashx?thn=1"/>

#5

Hope can have some clue. Have implemented to Production environment and is not working.


#6

The image size for summary large image cards should be larger. See the documentation.


#7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.