Image Metatag for Twitter Card


#1

Hi,
I can not validate the image meta tag to my Blogger, .
As you can see, the meta tag is correct, but the Card Validator not accept it, and it glows orange.
What should I do?
Thanks
Michele

<!-- twitter card details -->
<meta content='summary' name='twitter:card'/>
<meta content='@tradingweeks' name='twitter:site'/>
<meta content='@tradingweeks' name='twitter:creator'/>
<meta content='data:blog.url' name='twitter:url'/>
<meta content='data:blog.pageName' name='twitter:title'/>
<meta content='data:blog.metaDescription' name='twitter:description'/>
<meta content='data:blog.postImageThumbnailUrl' name='twitter:image'/>
<meta expr:content='data:blog.homepageUrl' name='twitter:domain'/>
<!-- end twitter card details -->

#2

my blog is http://tradingweeks.blogspot.it/
Michele


#3

Can you please post a URL that has all the tags that you are trying to validate?


#4

Hi, news for me?


#5

my page is http://tradingweeks.blogspot.it/


#6

Your metatag for image is wrong

This needs to be a valid image URL. I think you need to look into your blogging site’s settings to find out why data:blog.postImageThumbnailUrl is not being replaced by the image url.


#7

Hi,
thanks for your message.
I realized this, I was hoping you’d tell me what was wrong …
Those of Google are not able to help me.
Regards
Michele


#8

Have you taken a look at this? https://dev.twitter.com/docs/cards/twitter-cards-for-cms-wordpress-blogger-tumblr#Configuration-7


#9

Hi,
so it works, I have sent a request for approval.
Thanks
Michele


#10

Hi,
here now the card works properly, thanks for the support.

You know if I can install at the same time different TwitterCard and do their work depending on the types of posts?

Regards

Michele


#11

Hi,
I saw now that on my TwitterCard, instead of the name of my Twitter page (Tradinweeks), I see written "date: blog.pageName."
In practice, on the card I see the meta tag name instead of the Twitter page name.
Also, if I click the link, it sends me to my blog, not to the Twitter page.
Yesterday, when I validated the card, this meta tag was working properly, nothing has changed here.
My blog is http://tradingweeks.blogspot.com/
I write following the code of the card that you had sent me and that I put on my Blogger.
Let me know what I need to correct.
Thanks
Michele


#12

Can you try adding a expr:content, like the other tags?

For example:


#13

Hi
thanks for your message.
If I insert “expr” the card validator does not approve the card, without “expr” the card is validated, but then does not show the twitter name.
Regars
Michele