IE10 and the new Timeline Widget


#1

It’s a pretty big deal that the new Timeline Widgets don’t work on Internet Explorer 10. Why has this not been addressed yet?? Can someone please shed some light on what is going on please? I have 100s of these broken across our corporate sites and need an answer TODAY.

Thanks,
Jake


#2

Hi Jake.

The new timeline widget does work in IE10 (in fact, we support all versions of IE7+.) Can you please provide a link to one of the pages where it’s not working, and we can try to help debug and understand the issue.

Ben


#3

Hi Ben,

You can see the issue at all three of these sites:

And this happens every time we install a new widget to replace the old one. If it helps we’re looking at this in Windows 7 - IE10.

I really appreciate your help! We have lots of unhappy folks over here.

Thanks,
Jake


#4

It shows this error in the console:

SCRIPT5007: Unable to get property ‘appendChild’ of undefined or null reference
widgets.js, line 34 character 4443


#5

Thanks Jake. I can see the error on your site, and am looking into it now.


#6

Fantastic news! Really appreciate it!


#7

Hi Jake.

Quick follow up. I’ve narrowed down the issue, and we’ve got some code that should fix the initialization in IE10. The issue is that when you’re explicitly setting document.domain, our sandbox container also has to set the same domain, else it becomes inaccessible to the rest of the script. We have code that does this, but which has a fault in IE10. There are a billion edge-cases around IE’s security model across different versions, and unfortunately this one has slipped through. My apologies.

So, we’ve got where it will work, but that actually breaks some of the other security paths that IE can apply (such as the new CSP support), so this is going to take quite a lot of testing before we push the fix.

In the interim, there is a workaround that you can do on your side, which is to put IE into IE9 rendering mode, via a meta tag in your template. IE10 in IE9 mode appears to render the widget as expected even with document.domain set.

If you add this meta tag, you should be able to have it work immediately. Apologies, it’s not right to have to put things in your main template for sake of one widget, and we’ll try to get a fix out that works in every permutation of IE’s security model as soon as we can.

The IE rendering override is this:

Regards,

Ben


#8

Hi Ben,

Thank you for all the work you’ve done in looking into this issue. I’ve tried installing that meta tag on all of our sites and it still doesn’t fix the issue. You can see it for yourself via http://www.thesky973.com/. Am I doing something wrong? Any other thoughts or suggestions?

Again - I really appreciate your help on this!

Thanks,
Jake


#9

Hi Ben,

Thanks again for looking at our issue last week. As my last comment stated - the fix you recommended did not work unfortunately. I have the tag installed on http://www.thesky973.com/ - but no dice.

Could you possibly recommend another work around or take a look at the page and let me know if I’m doing something wrong with that tag?

Thanks so much!
Jake


#10

I am experiencing this same issue. I tried the meta tag and it did not work for me. Any other solution would be very much appreciated.


#11

Hi Guys,

Apologies that the tag didn’t have the desired effect. I got muddled between IE’s ‘browser mode’ and ‘document mode’; setting a browser mode of IE9 works, but the document mode makes no difference. Unfortunately you cannot set the browser mode in a meta tag, so this is going to require a fix on our side. I’m working on that right now and hope to deploy it today or tomorrow. (We have a gnarly conflict between the error here—where document.domain is explciitly set in IE10—and the behaviour of the widget when the server sets new Content Security Policy headers. It’s taking a little while to work between those two different edge cases but we’ve nearly got it sussed.)

Ben


#12

Fantastic news Ben! Again - I (and everyone on my team) so appreciate your help!

Thanks,
Jake


#13

Hi Jake,

We put out a deploy this afternoon that should fix the widget initialization in IE10. Please let me know.

Ben


#14

It totally works!! You saved the day Ben! I can’t tell you how much we appreciate your assistance with this!

My day just got MUCH better…

Take care,
Jake


#15

Hi

Now it’s MY turn to struggle with this? Widget is a total No-no in IE10?? Help?


#16

Thanks Ben, it also works for our Intranet.


#17

My Twitter timeline widget is no longer working in IE10 either. It works in Chrome and Firefox. Please advise


#18

I just checked in IE10 and my widget is still showing perfectly fine. There is most likely another JS error somewhere on your page that is causing a conflict. Have you checked the JavaScript console for errors?


#19

I have tried the 3 links you mentioned above via IE10, but none of it were working for me. Currently I have the same issue, in the site. www.digitalopinion.co.uk

anyone know what exactly going on here?


#20

Are you guys seeing this on Windows 7 IE10 or Windows 8 IE10? It’s for sure working in Windows 7 IE10.

@benward - are you seeing this issue again?