"id parameter is missing" error message


#1

Dear Sir/Madam,

having issues with your REST API (v1.1). I can do GET-requests, but I am having big issues with POST-requests.

I want to remove some favorites and therefore I need to go to

   https://api.twitter.com/1.1/favorites/destroy.json

and in the body post “id=987688972347823” for example. But when I do this I am getting or “sorry, this page does not exist” or “id parameter is missing” depending if I adjust the headers being sent. Apparantly since the switch from v1 to v1.1 I am having these issues, but only noticed this last week.
I am using Node JS with the “request” module of mikeal (which has always worked for me in many situations), but today I tried your Oauth singing tool (https://dev.twitter.com/apps/4031072/oauth?nid=10606) which resulted in a cURL command that I cannot execute. Sometimes it works and sometimes it doesn’t (I execute them right away).

request.post({ url:'https://api.twitter.com/1.1/favorites/destroy.json', body:'id=459671820606918660', oauth:oauth },function(err2,data){ console.log(err,data); });

where oauth is an object

var oauth = { consumer_key:'xxxx', consumer_secret:'xxxx', token:'xxxx', token_secret:'xxxx' };

which should be fine. My problem is not using this module, but that the GET-request works, but the POST-request is having issues while I am following all the default settings, right?

With kind regards,

Joey


#2

I have found the following workaround

https://api.twitter.com/1.1/favorites/destroy.json?id=459671820606918660

With kind regards,

Olav